Page MenuHomePhabricator

Message MediaWiki:Apihelp-protect-example-unprotect seems self-contradictive.
Closed, ResolvedPublic

Description

Setting restrictions to "all" shoul maximize its protection not lift it.

URL: https://translatewiki.net/wiki/MediaWiki:Apihelp-protect-example-unprotect/en

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 26 2016, 3:07 PM
Anomie closed this task as Invalid.Jul 26 2016, 3:12 PM
Anomie added a subscriber: Anomie.

And yet that's the way it works. Setting the restriction to "edit=sysop" means editing is restricted to sysops (or more specifically, to anyone with the 'editprotected' right). Setting the restriction to "edit=all" means everyone is allowed to edit.

Purodha reopened this task as Open.Jul 26 2016, 11:39 PM

Please update whatever is needed - message text, message documentation, etc. As it is, it not i18n-able.

@Purodha: Please explain what exactly is unclear about the sentence
"Unprotect a page by setting restrictions to all."
as the message text seems to be correct. If it is not i18n-able for some reason, please propose a text that is i18n-able.

@Purodha: Please explain what exactly is unclear about the sentence
"Unprotect a page by setting restrictions to all."
as the message text seems to be correct. If it is not i18n-able for some reason, please propose a text that is i18n-able.

Compare with message MediaWiki:Apihelp-protect-example-unprotect2/en
https://translatewiki.net/wiki/MediaWiki:Apihelp-protect-example-unprotect2/en "Unprotect a page by setting no restrictions."

If restrictions are set to "all", the page protection is at a maximum, because every possible restriction is in place protecting the page.

I cannot make proposals for a text which I do not understand. Forgive me for not digging through the source code attempting to find out what happens when the message is used and eventually confirmed. :-( It took me already more than half an hour to find the abovementioned message due to translatewiki.net's - erm - limited search capabilities. I had seen it a few days ago, but neither fully remembered its text nor its message key,

Ah. Well, mentioning MediaWiki:Apihelp-protect-example-unprotect2/en definitely brings up the valid issue of consistency here, I'd say. Thanks!

I already told you what it means. The restrictions specify who is allowed to take the action, not who is not allowed to take the action. Restricting editing to "all" is effectively not restricting editing since it means everyone can edit it, just like restricting editing to "sysop" means sysops can edit it.

Change 301366 had a related patch set uploaded (by Anomie):
API: Document a level of 'all' in action=protect

https://gerrit.wikimedia.org/r/301366

Anomie moved this task from Unsorted to Needs Review on the MediaWiki-API board.Jul 27 2016, 1:34 PM

Well, I understood what is meant. I am not a native English speaker. Asking three non-natives whom I just caught on he fly, a group of two and another one, told me that they did not understand what is meant. I only asked them: "Can you tell me what this means: ..." - "thank you"

Thus, the wording is ambigous at least. Likely, we should try to avoid the word "restrictions" since 'restricting to what' and 'restricting for whom' or 'keeping ... from ...' etc. is too uncertain and too easily messed up.

Change 301366 merged by jenkins-bot:
API: Document a level of 'all' in action=protect

https://gerrit.wikimedia.org/r/301366

Anomie closed this task as Resolved.Jul 29 2016, 2:31 PM
Anomie claimed this task.

The messages now clearly explain what all does.