Page MenuHomePhabricator

Fix font support on SauceLabs VE screenshots
Closed, ResolvedPublic0 Story Points

Description

Failures at normal size:
KM (Khmer)

Failures when scaled up:
AZB (South Azerbaijaini)

AR (Arabic)

FA (Farsi)

JA (Japanese)

KM (Khmer)


KN Kannada

OR (Odia/Oriya)

PS (Pashto)

SD (Sindhi)

TA (Tamil)

Event Timeline

Esanders created this task.Jul 26 2016, 3:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 26 2016, 3:14 PM
Esanders updated the task description. (Show Details)Jul 26 2016, 3:24 PM
Esanders assigned this task to zeljkofilipin.
Jdforrester-WMF triaged this task as Normal priority.

Is this because it runs on a Windows box? Can we change it to use Linux?

Jdforrester-WMF set the point value for this task to 0.Aug 12 2016, 8:24 PM

@Esanders apologies for the late reply, I was on vacation. As far as I remember, the best font support was on Mac. I will change the OS to Mac and Linux and see which one is the best.

I am not sure what the problem is here. The screenshots look fine to me.

zeljkofilipin moved this task from Next to In Progress on the Browser-Tests-Infrastructure board.

screenshots.yml says the job is running on Linux:

BROWSER:
  - chrome

PLATFORM:
 - Linux

Change 305786 had a related patch set uploaded (by Zfilipin):
WIP Run language screenshots on OS X 10.11

https://gerrit.wikimedia.org/r/305786

This comment was removed by zeljkofilipin.
zeljkofilipin added a comment.EditedAug 23 2016, 10:42 AM

The job is running using Chrome browser.

Linux, #26, 2 hr 33 min, 801 passing, 5 failing, 1.785 filesMac, #27, 3 hr 16 min, timed out, 846 filesMac, #28, 3 hr 2 min, 279 passing, 86 failing, 821 filesWindows, #30, 3 hr 10 min, 737 passing, 18 failing, 1.894 files
ar
azb
fa
ja
km
kn
or
ps
sd
ta

@Esanders @Amire80 @Elitre: Please take a look at the screenshots and let me know which OS is preferred.

Change 305786 merged by jenkins-bot:
Run language screenshots on Windows

https://gerrit.wikimedia.org/r/305786

The last one for Tamil doesn't look right?

@Elitre sorry, you will have to be more specific :) there are a lot of screenshots around. Are you referring to the original screenshots, or the linux/mac/windows table I have created?

@Elitre, @Esanders, @Amire80 Are the fonts now fixed? Images from the last build (on Windows) are here:

The last comments were a week ago. If there are no responses in the next day or two, I will resolve the task.

zeljkofilipin closed this task as Resolved.Aug 31 2016, 9:41 AM

Assuming the fonts are fine now. Please reopen if there are anything left to fix.