Page MenuHomePhabricator

[betalabs-Regression] Special:Notifications - the pagination does not follow default pattern of 50 messages per page
Closed, ResolvedPublic

Description

Betalabs 1.28.0-alpha (420c520)

  1. Login as a user with more than one page messages - i.e. >50
  2. Go to Special:Notifications page.

User ET8 has 99+ messages.
The first page displays in pagination 1-43


The second page displays 51-73

The screen recording shows a different case - the pagination gets broken on the third page.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 27 2016, 6:20 PM
Etonkovidova updated the task description. (Show Details)Jul 27 2016, 6:24 PM

Change 301382 had a related patch set uploaded (by Sbisson):
[WIP] Moderate notifications

https://gerrit.wikimedia.org/r/301382

This is caused by the way we filter unrenderable events. This patch (https://gerrit.wikimedia.org/r/301382) tries to fix it by moderating events that cannot be rendered so they are filtered out at the db level on subsequent fetches.

SBisson claimed this task.Jul 29 2016, 2:10 PM
SBisson moved this task from Untriaged to Needs Review on the Collab-Team-Q1-July-Sep-2016 board.

Change 301382 merged by jenkins-bot:
Moderate notifications

https://gerrit.wikimedia.org/r/301382

Checked in betalabs

jmatazzoni closed this task as Resolved.Sep 12 2016, 8:50 PM