Page MenuHomePhabricator

[Regression] Fix browser tests for language switching on the beta cluster
Closed, ResolvedPublic1 Story Points

Description

Not a regression in the language switcher or the button.

On the beta cluster we run the full set of browser tests. Currently these are failing since https://gerrit.wikimedia.org/r/#/c/301351/9
They are failing because the LocalSettings.php does not get loaded on the beta cluster.

A/C

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 29 2016, 6:29 PM
Jdlrobson updated the task description. (Show Details)Jul 29 2016, 6:30 PM

Change 301858 had a related patch set uploaded (by Jdlrobson):
Fix the browser test failures

https://gerrit.wikimedia.org/r/301858

Jdlrobson updated the task description. (Show Details)Jul 29 2016, 6:40 PM

Change 301861 had a related patch set uploaded (by Jdlrobson):
Enable new language bar on beta cluster

https://gerrit.wikimedia.org/r/301861

Change 301861 merged by jenkins-bot:
Enable new language bar on beta cluster

https://gerrit.wikimedia.org/r/301861

Jdlrobson closed this task as Resolved.Aug 1 2016, 4:14 PM
Jdlrobson claimed this task.
MBinder_WMF renamed this task from Fix browser tests for language switching on the beta cluster to [Regression] Fix browser tests for language switching on the beta cluster.Aug 1 2016, 4:14 PM
MBinder_WMF reopened this task as Open.
MBinder_WMF removed Jdlrobson as the assignee of this task.
MBinder_WMF triaged this task as High priority.
MBinder_WMF updated the task description. (Show Details)
MBinder_WMF set the point value for this task to 1.
phuedx reassigned this task from Jdlrobson to dr0ptp4kt.Aug 1 2016, 4:42 PM
phuedx updated the task description. (Show Details)

@Jdlrobson @phuedx Is https://gerrit.wikimedia.org/r/301858 part of this task? It's marked with the bug, yet not merged despite this task being Ready for Signoff.

Change 301858 abandoned by Jdlrobson:
Fix the browser test failures

https://gerrit.wikimedia.org/r/301858

No. It wasn't needed. I forgot to abandon after realising I was going down the wrong rabbit hole. This task is merged and just needs sign off.

@phuedx, @jhobs, @bmansurov for your engineer signoff.

jhobs claimed this task.Aug 2 2016, 5:28 PM
jhobs added a subscriber: dr0ptp4kt.

A new build is running at the moment due to what seems like an API failure. I'll sign off if everything is green when it has finished.

All scenarios are failing with the error described in T129483.

See T129483. This is not only a problem with us but with other extensions. Early theories are no longer valid. Not sure what's going on here.

phuedx changed the task status from Open to Stalled.Aug 4 2016, 3:19 AM
phuedx added a comment.Aug 8 2016, 9:02 AM

The last four builds are green. Per the AC, this is Resolved.

jhobs closed this task as Resolved.Aug 11 2016, 4:55 PM
jhobs removed jhobs as the assignee of this task.