Page MenuHomePhabricator

{{Expansion depth limit exceeded}}
Closed, ResolvedPublic

Description

Hello Cindy,

I'm still not sure how and why this bug was triggered, but on one wiki we're managing, Semantic Title is running into {{Expansion depth limit exceeded}} errors. This happens for (almost) every page link that gets its label by Semantic Title. Strange thing is, the wiki was already running fine before.

The link itself works, it's just the label that's broken.

We recently tried to enable caching but have disabled it again. The wiki had issues with its job queue, having more jobs than it could process.
The wiki runs on MW 1.25 and SMW 2.4.1

Do you have any idea why this is happening? Maybe some recursion when fetching the label?

Best,
Simon

Event Timeline

Fannon created this task.Aug 5 2016, 7:42 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 5 2016, 7:42 AM

Hi, Simon.

Sorry for not responding sooner. I just returned from vacation.

No, I haven't seen that before and don't know what could be causing it. Is it still an issue? You say the wiki was running fine before. Do you know what changed before the error started occurring?

Cindy

Fannon closed this task as Resolved.Aug 16 2016, 6:05 AM

Hello Cindy,

I hope you had a nice vacation! :)

I think we fixed this weird bug. The involved wiki was still running SMW 2.4 RC1 and had some issues with storing data correctly and crashing on some jobs. Maybe something went wrong there.

We could fix the bug by upgrading SMW 2.4.1 and applying a purge on all wiki pages in the wiki. Just running rebuildData wasn't enough, as the root cause seemed to be invalid/broken entries in the page_props table.

Best,
Simon

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJul 31 2019, 3:46 PM