Page MenuHomePhabricator

New notification badge acts funny on Opera 12
Closed, ResolvedPublic

Description

The new notification badge acts funny on Opera 12. Symptoms include:

  • The badge flashes on and off during the loading of the page, and when hovered
  • Occasionally tabs have high CPU usage, even on background tabs (doing nothing)
  • During loading of the page, area in top-right corner of the page is sometimes clickable, leading to Special:Notifications

For whatever reason, all this seems to be caused by using an SVG image in content property in CSS.

Event Timeline

matmarex created this task.Aug 5 2016, 7:17 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptAug 5 2016, 7:17 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
matmarex claimed this task.Aug 5 2016, 7:17 PM
matmarex triaged this task as Lowest priority.

Change 303253 had a related patch set uploaded (by Bartosz Dziewoński):
mw.echo.badge: Use 'background-image' rather than 'content'

https://gerrit.wikimedia.org/r/303253

Change 303253 merged by jenkins-bot:
mw.echo.badge: Use 'background-image' rather than 'content'

https://gerrit.wikimedia.org/r/303253

Checked the issues described in the task in Opera 39.0 (Windows) - none of the issues are present.

The screenshots for the record:

jmatazzoni closed this task as Resolved.Aug 9 2016, 6:18 PM