Page MenuHomePhabricator

Update npm to 2.x on tools
Closed, DeclinedPublic

Description

Npm 1 is very old and is unstable, whereas npm 2 is still supported and is used by nodejs 4.x.

npm 1 is very unstable with nodejs 1 so we should upgrade npm please.

Event Timeline

Paladox created this task.Aug 5 2016, 7:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 5 2016, 7:54 PM
tom29739 renamed this task from Update npm to 2.x on lolrrit-wm to Update npm to 2.x on tools.Aug 5 2016, 7:59 PM
tom29739 added a project: Toolforge.
tom29739 updated the task description. (Show Details)
tom29739 added a subscriber: tom29739.

Are you sure the version of npm *inside* kubernetes is too old?

Paladox added a comment.EditedAug 5 2016, 8:01 PM

doing webservice --backend=kubernetes nodejs shell

and then npm -v shows it is using 1.4

You need to do
webservice --backend=kubernetes nodejs shell

Paladox added a comment.EditedAug 5 2016, 8:03 PM

Yep, I did that, and it shows npm 1.4

we had problems on ci when we mixed npm 1.x with nodejs 4

tools.lolrrit-wm@interactive:~$ npm -nv
o1.4.21

yuvipanda closed this task as Declined.Aug 23 2016, 6:24 AM

I'm going to decline this right now for tools overall, since we don't really want to install things outside of debian packaged setup. If there are specific bugs that are caused by this, please open another bug (or re-open this) with more details.