Page MenuHomePhabricator

UI Regression: PointerOverlay's are broken
Closed, ResolvedPublic3 Estimated Story Points

Description

Visit https://en.m.wikipedia.org/w/index.php?title=Foozbar&article_action=signup-edit while logged in
Expected:

Actual:

Click the hamburger menu
Expected: Pointer overlay closes
Actual:

Acceptance criteria

  • UI regression removed
  • When I click the hamburger menu (the icon in the top left) the pointer overlay disappears

Developer notes

  • A class is being used that shouldn't - use pointer-overlay-tutorial not tutorial-overlay class
  • Inside skins.minerva.newusers you'll want to bind to the hamburger menu icon and hide the overlay when the pointer overlay is clicked. Alternatively consider require the passing of a MainMenu instance into all PointerOverlays.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 10 2016, 3:19 PM

This a more general problem and happens with toasts and possibly other similar items too. @Nirzar, do you think we should hide such things when the hamburger is tapped? To re-produce, go to https://en.m.wikipedia.org/wiki/Book and click on the edit pencil icon. You'll see a "vandalism..." message, then click on the hamburger menu. You'll see that the toast won't go away.

do you think we should hide such things when the hamburger is tapped?

Yes. hamburger should focus on the opening panel. we don't want to split attention.

jhobs triaged this task as Medium priority.Aug 10 2016, 5:41 PM
jhobs added a subscriber: jhobs.

Triaged as Normal over High since the toasts and tooltips still disappear properly and it is probably not the most likely scenario upon which a user will stumble.

Jdlrobson renamed this task from PointerOverlay's should close on menu open to UI Regression: PointerOverlay's are broken.Apr 17 2017, 6:14 PM
Jdlrobson updated the task description. (Show Details)
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptApr 17 2017, 6:14 PM
Jdlrobson updated the task description. (Show Details)Apr 17 2017, 6:14 PM
Jdlrobson updated the task description. (Show Details)May 3 2017, 11:37 PM
Jdlrobson set the point value for this task to 3.May 4 2017, 5:20 PM

Change 353191 had a related patch set uploaded (by Bmansurov; owner: Bmansurov):
[mediawiki/extensions/MobileFrontend@master] Edit overlay fixes

https://gerrit.wikimedia.org/r/353191

Change 353191 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Sign up edit tutorial fixes

https://gerrit.wikimedia.org/r/353191

bmansurov removed bmansurov as the assignee of this task.May 11 2017, 2:24 PM

@Jdlrobson - tried testing this on a few pages (which do not exist) - I'm getting a "this page is protected to prevent vandalism" error everywhere.

@ovasileva are you logged in? What user account are you using? A new one or your own?

ovasileva closed this task as Resolved.May 15 2017, 9:52 AM

Tested on the beta cluster - all done.