Page MenuHomePhabricator

[Bug] Tapping delete button on text field for Find in Page should show the keyboard if it is not showing.
Closed, ResolvedPublic

Description

I just noticed a bit of unintended behaviour when swiping the screen up or down when find in page is active.

Steps to reproduce / testing criteria

  1. Tap 'Find in page' icon in an article and start typing a word with multiple matches on the screen.
  2. Use swipe down gesture on the screen to scroll down the screen.
  3. Tap the small circular "x" inside the search input box at the bottom of the screen.
  4. When you do this the search box is cleared, but the keyboard doesn't re-appear.

Expected
Keyboard should re-appear when you perform step 4 above.

Event Timeline

JMinor created this task.Aug 15 2016, 6:31 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 15 2016, 6:31 PM
JMinor triaged this task as Low priority.Aug 15 2016, 8:30 PM

After chatting with Monte, hiding this element on collapse is not trivial.

I'd suggest that we leave this visible in collapsed state, but if the user touches this element we re-open the keyboard on the assumption the user actually wants to delete the text she is searching for and enter new text.

RHo updated the task description. (Show Details)Aug 16 2016, 8:32 PM
JMinor lowered the priority of this task from Low to Lowest.Aug 22 2016, 6:12 PM
julbod claimed this task.Feb 12 2017, 7:23 PM
Mhurd added a subscriber: Mhurd.Feb 15 2017, 10:11 PM

@JMinor Heads-up I'm going to update the description to describe what we actually did to fix this.

Mhurd renamed this task from [Bug] Delete button on text field for Find in Page should not show in collapsed state. to [Bug] Tapping delete button on text field for Find in Page should show the keyboard..Feb 15 2017, 10:14 PM
Mhurd renamed this task from [Bug] Tapping delete button on text field for Find in Page should show the keyboard. to [Bug] Tapping delete button on text field for Find in Page should show the keyboard if it is not showing..
Mhurd updated the task description. (Show Details)

I've updated the description / title of this ticket to better describe what we ended up doing.

The updated description should suffice as testing criteria now as well.

cmadeo added a subscriber: cmadeo.Feb 17 2017, 11:47 PM

@Mhurd unfortunately I'm not seeing the keyboard re-appear when I tap on the clear button. Additionally when I clear the text and then tap in the empty search box it occasionally glitches/flickers or takes two taps to open the keyboard. The keyboard is appearing correctly when I tap in the search box without clearing the text, however.

Tangential, but I'm not sure if the usage of the blue 'Done' button on the keyboard is correct. I was surprised when hitting the 'Done' button closed find in the page, generally I associate these buttons with actions related to submitting content not dismissing views.

To back this up, here are some screenshots from 'Search this page' on Safari:

Search this page without textSearchingAfter hitting the blue 'search' button on the keyboard

I can file a design bug for this separately if needed :)

@cmadeo oops I'm not sure we've cut a build since my fix was merged.

@cmadeo we can change the "done" button behavior too but I'd prefer to address that in a separate ticket if that's ok

Thanks @Mhurd created one here: T158457

For the most part this looks good, however if you attempt tap into the search box while the article is scrolling the search box flickers. This is only a problem because in order to stop the article from scrolling quickly it's easy to dismiss search inside by tapping on the article text.

It appears to be fixed, but only if the page is not still scrolling. I think this is the behavior @cmadeo was referring to above. If the page is still scrolling the bug as it is described still happens. Is this a separate bug?

Testing on iPhone 6S (iOS 10) and Wikipedia 5.4.0 (1080) app. There is still an issue with the keyboard not reappearing when tapping the x:

JMinor added a comment.Mar 2 2017, 5:45 PM

It appears to be fixed, but only if the page is not still scrolling. I think this is the behavior @cmadeo was referring to above. If the page is still scrolling the bug as it is described still happens. Is this a separate bug?

I would consider that part of this bug. I'm willing to take the partial improvement, but I don't think this is totally fixed.

julbod added a comment.EditedMar 8 2017, 2:59 AM

Pull request that resolves the scroll bug: https://github.com/wikimedia/wikipedia-ios/pull/1263

julbod removed julbod as the assignee of this task.Mar 10 2017, 3:21 PM
julbod added a subscriber: julbod.
JMinor closed this task as Resolved.Mar 20 2017, 6:07 PM