Page MenuHomePhabricator

VisualEditor loading stuck on blue bar if you click the Edit tab twice during loading
Closed, ResolvedPublic1 Story Points

Description

Today, I went to test.wikipedia.org (post train deployment), hit "Random page" and clicked the "Edit" tab. It didn't ask me what editor I wanted and started loading the VIsualEditor. It was taking a long time to load, so I hit the "Edit" tab again (which I know doesn't make sense). This caused it to become frozen on a full progress bar and throw 2 JS errors, both of which were:

TypeError: step is undefined

The error is semi-reproducible. Just click the Edit tab again during the middle of the VisualEditor loading process. Sometimes it will error, sometimes it won't. Seems to be timing related. [Only tested in Firefox.]

Event Timeline

kaldari created this task.Aug 16 2016, 9:48 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 16 2016, 9:48 PM
kaldari updated the task description. (Show Details)Aug 16 2016, 9:51 PM

Change 306240 had a related patch set uploaded (by DLynch):
init: Don't set an invalid progress state when loading

https://gerrit.wikimedia.org/r/306240

Jdforrester-WMF renamed this task from VisualEditor loading stuck on blue bar if you click the Edit tab twice to VisualEditor loading stuck on blue bar if you click the Edit tab twice during loading.Aug 23 2016, 7:22 PM
Jdforrester-WMF assigned this task to DLynch.
Jdforrester-WMF triaged this task as High priority.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.
Jdforrester-WMF set the point value for this task to 1.

Change 306240 merged by jenkins-bot:
init: Discard attempts to activate while we're already activating

https://gerrit.wikimedia.org/r/306240

Jdforrester-WMF closed this task as Resolved.Aug 25 2016, 9:00 PM