Page MenuHomePhabricator

Metrics for 2015-2016 audit report
Closed, ResolvedPublic

Description

Fill in the blanks:

For the year ended June 30, 2016, the educational content of the Foundation’s largest project, Wikipedia, grew by approximately ___ million articles to more than ___ million articles total.
• For the year ended June 30, 2016, volunteers added approximately ___ million images, movies, and sound files to the Foundation’s multimedia repository, making the total ____ million files.
• Volunteers also contribute in several ways to the Foundation’s wiki software: volunteer software developers add new functionality to the code base, and volunteer language specialists add to the code base by translating the wiki interface into different languages. As of ________, the Foundation had ________ commits merged, form which _________ were accepted in the past 365 days through the effort of approximately _______ contributors, in which approximately ______ are active contributors.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 19 2016, 10:04 PM
ezachte closed this task as Resolved.Aug 23 2016, 1:46 PM

Answers supplied to Tony Le (minus the links), with thanks to Quim and Andre

For the year ended June 30, 2016, the educational content of the Foundation’s largest project, Wikipedia, grew by approximately 5.2 million articles to approximately 40.6 million articles total. [1]

For the year ended June 30, 2016, volunteers added approximately 6.1 million images, movies, and sound files to the Foundation’s multimedia repository, making the total 33.1 million files. [2]

Volunteers also contribute in several ways to the Foundation’s wiki software: volunteer software developers add new functionality to the code base, and volunteer language specialists add to the code base by translating the wiki interface into different languages. As of mid August 2016, the Foundation had approximately 452 thousand commits merged, through the efforts of approximately 2000 contributors, from which 29 thousand commits were accepted in the past 365 days, through the efforts of approximately 490 active contributors. [3] [4]

[1] https://stats.wikimedia.org/EN/TablesWikipediaZZ.htm
[2] http://reportcard.wmflabs.org/graphs/commons
[3] Andre now owns volunteer metrics
[4] numbers rounded from
1,988 code contributors in total, 491 active in the past 365 days
(Quim: The reduction of the total amount of contributors is caused by some pruning we did in the repositories we were scanning, which included some local forks of open source projects developed elsewhere).
452,173 patches contributed, from which 28,908 have been merged in the past 365 days.
All this according to http://korma.wmflabs.org/browser/

DarTar moved this task from Staged to Done (current quarter) on the Research board.