Page MenuHomePhabricator

Gender dependant namespaces "User" and "User talk" should be updated on Slovak Wikipedia
Closed, ResolvedPublic

Description

Hello! We have a little problem on Slovak Wikipedia: namespaces "User" and "User talk" changed somewhen on 18th of August to "Uživatel" and "Diskuse s uživatelem".
It should be "Redaktor" ("User" - instead of "Uživatel") and "Diskusia s redaktorom" ("User talk" - instead of "Diskuse s uživatelem").
It is not happening to all users, just to some of them (for example:
https://sk.wikipedia.org/wiki/Uživatel:Vasiľ
https://sk.wikipedia.org/wiki/Uživatel:OJJ
https://sk.wikipedia.org/wiki/Uživatel:Maajo25
etc.)
Thank you very much!

Local project discussion
https://sk.wikipedia.org/wiki/Wikip%C3%A9dia:Kr%C4%8Dma/Technick%C3%A9#Zmena_menn.C3.A9ho_priestoru_.E2.80.9ERedaktor.E2.80.9C_na_.E2.80.9EU.C5.BEivatel.E2.80.9C

Root causes

  • In 2011, cs.wikipedia wants gender localisation (T35367). This is committed as 65ab9bf6.
  • In 2016, TranslateWiki discussion occurs to offer a fallback between Cs and Sk languages. This is committed as b321f48d80db and deployed during the last MediaWiki train.
  • MediaWiki respects namespaceGenderAliases if they exist. As they don't exist in Sk messages, it checks the fallback, anf found it on Cs.

Solution

  1. For MediaWiki core, and so every MediaWiki installations using Slovak language, offer a proper Slovak localisation (tracked separately as T143474).
  2. For Slovak Wikipedia, a specific configuration to use their own namespaces choices.

Namespace localisation

@LacoR summarized the expected namespaces localisation as this:

NS_USERNRedaktor
NS_USERMRedaktor
NS_USERFRedaktorka
NS_USER_TALKNDiskusia s redaktorom
NS_USER_TALKMDiskusia s redaktorom
NS_USER_TALKFDiskusia s redaktorkou

Details

Related Gerrit Patches:
operations/mediawiki-config : masterSet User namespace aliases on sk.wikipedia
operations/mediawiki-config : masterRestore Redaktor namespace on sk.wikipedia
operations/mediawiki-config : masterFix user namespaces on Slovak Wikipedia

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 20 2016, 10:35 AM
Restricted Application added subscribers: JEumerus, Matanya. · View Herald TranscriptAug 20 2016, 10:38 AM
Dereckson triaged this task as High priority.Aug 20 2016, 10:43 AM
Dereckson added a subscriber: Dereckson.

[ Set priority to high per the inconsistency ]

A purge on an user page doesn't change the namespace between Uživatel and Redaktor.

https://sk.wikipedia.org/w/api.php?action=query&meta=siteinfo&siprop=namespaces%7Cnamespacealiases gives expected information:

"2": {
                "id": 2,
                "case": "first-letter",
                "subpages": "",
                "canonical": "User",
                "*": "Redaktor"
            },
            "3": {
                "id": 3,
                "case": "first-letter",
                "subpages": "",
                "canonical": "User talk",
                "*": "Diskusia s redaktorom"
            },
Dereckson added a comment.EditedAug 20 2016, 10:47 AM

I wonder if it's not a gender issue: if the user declares themselves as identified as a woman, it will use Uživatel.

Yes, this is well preference-related:

NRedaktor:Dereckson
FUživatelka:Dereckson
MUživatel:Dereckson
Dereckson renamed this task from Namespaces "User" and "User talk" are changed on Slovak Wikipedia to Gender dependant namespaces "User" and "User talk" should be updated on Slovak Wikipedia.Aug 20 2016, 10:50 AM

So to move forward, could you ask on the wiki what we should use as namespace for the users who identify as a woman?

TomasPolonec added a comment.EditedAug 20 2016, 10:56 AM

It should be only "Redaktor" and "Diskusia s redaktorom" for talk namespace for all users.

So, currently, any user who want to get back Redaktor can go to the preferences and opt for a neutral language.

Monday, we can also deploy a config update to use Redaktor for users who identify as a man.

But an on-wiki discussion should occur to localize the namespace for users who identify as a woman too, if not we we'll have Redaktor: and Uživatelka:, which wouldn't be consistent.

For years it was only "Redaktor" what is unisex word. Uživatel/Uživatelka and Diskuse s uživatelem/uživatelkou are wrong at all because it could be "Užívateľ/Užívateľka" and "Diskusia s užívateľom/užívateľkou". But we had "Redaktor" for years for all users, it changed to "Uživatel"... just two days ago...

You're requesting a configuration change.

Per https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes,
this is your responsibility to "gather local on-wiki community consensus
for the change".

The MediaWiki software evolves, and any configuration change to react to
the software evolution must be wanted by the community.

Could I know who changed it two days ago? Because it is grammaticaly wrong too (it is not in slovak language but in czech).

Two days ago (Thursday) was the day MediaWiki wmf/1.28.0-wmf.15 branch was deployed on Wikipedia projects. So there is probably a namespace change in this version.

I've filled another bug, T143474 to fix in the MediaWiki software the localisation in Slovak.

Could you check the strings on the table there?

Lisiak added a subscriber: Lisiak.Aug 20 2016, 12:22 PM

I suppose, it would be best to use:

N Redaktor: Diskusia s redaktorom:
F Redaktorka: Diskusia s redaktorkou:
M Redaktor: Diskusia s redaktorom:

"Redaktorka" si feminine version of noun "redaktor", although it is worth noting that Slovak language uses masculine nouns as gender neutral (e.g. when addressing users it is not neccessary to say "Vážení redaktori a redaktorky", just "Vážení redaktori").

A lot of languages uses indeed masculine nouns as gender neutral. That's fine, as the MediaWiki software lets the choice for anyone between the neutral (and so here masculine noun Redaktor) or the feminine version (and so here Redaktorka).

As the neutral choice is set by default in the preferences for new users, Redaktorka would be an opt-in feature for those who want it.

Change 305785 had a related patch set uploaded (by Dereckson):
Fix user namespaces on Slovak Wikipedia

https://gerrit.wikimedia.org/r/305785

I've prepared a patch based on task description and Lisiak input.

We'll wait green light from the community per T143472#2569400 to deploy it.

Dereckson added a comment.EditedAug 20 2016, 1:24 PM

Could I know who changed it two days ago? Because it is grammaticaly wrong too (it is not in slovak language but in czech).

The probable cause is b321f48d: for the Czech language, gender localized namespaces are already configured per 65ab9bf6 (T35367).

So when the fallback Sk->Cs have been deployed, you've automatically got the missing language configuration from Czech.

Dereckson updated the task description. (Show Details)Aug 20 2016, 1:31 PM
Dereckson updated the task description. (Show Details)
Dereckson updated the task description. (Show Details)Aug 20 2016, 1:34 PM
LacoR added a subscriber: LacoR.Aug 20 2016, 2:28 PM

Could I know who changed it two days ago? Because it is grammaticaly wrong too (it is not in slovak language but in czech).

The probable cause is b321f48d: for the Czech language, gender localized namespaces are already configured per 65ab9bf6 (T35367).
So when the fallback Sk->Cs have been deployed, you've automatically got the missing language configuration from Czech.

Just for information when setting language to cs (czech) and gender to F then than namespace is "Wikipedistka" and not "Uživatelka" - so it its possible, that there is something more missing in the sk translation

LacoR added a comment.Aug 21 2016, 3:54 PM

Just for my better understanding two questions:

  1. Is it realy neccesery to start a formal voting on Slovak wikipedia regarding the change for this settings:
NS_USERNRedaktor
NS_USERMRedaktor
NS_USERFRedaktorka
NS_USER_TALKNDiskusia s redaktorom
NS_USER_TALKMDiskusia s redaktorom
NS_USER_TALKFDiskusia s redaktorkou
  1. Is it neccesery to start an other task here on pahbricator for this change?

From my point of view it is not a real change of settings, just an adding because of the change of the language fallback.

Dereckson added a comment.EditedAug 21 2016, 3:58 PM

Formal voting or smaller discussion?

As far as we're concerned, you need to discuss the matter on Slovak Wikipedia and get an agreement there. There is already currently a discussion. From a site requests handling point of view, that's enough.

You're better placed than us to know if Slovak Wikipedia usages requires or not a formal voting for that. I'll defer to your opinion on the matter.

Task scope

This task is about fixing the namespaces for sk.wikipedia, so no there is no need for another task.

Dereckson updated the task description. (Show Details)Aug 21 2016, 4:25 PM
LacoR added a comment.Aug 21 2016, 6:27 PM

@Dereckson Thanks for your answer. I have started a 24 hour survey on the quoted discussion on the Slovak wikipedia, which will give a consensus fo our community.

LacoR added a comment.Aug 22 2016, 7:09 PM

On the slovak wikipedia there is a clear consensus about fixing this issue - voting here.

And once more - this is not a real change of settings - it is just a fix after a change (T143519), which was made without any discussion on the slovak wikipedia.

Change 305785 merged by jenkins-bot:
Fix user namespaces on Slovak Wikipedia

https://gerrit.wikimedia.org/r/305785

Mentioned in SAL [2016-08-22T23:19:03Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Fix user namespaces on Slovak Wikipedia (T143472) (duration: 00m 58s)

Dereckson closed this task as Resolved.Aug 22 2016, 11:21 PM
Dereckson moved this task from To deploy to Done on the Wikimedia-Site-requests board.
Terbium
$ mwscript namespaceDupes.php skwiki --fix
0 pages to fix, 0 were resolvable.

pagelinks from=337181 ns=0 dbk=Redaktorka:nelliette -> Redaktorka:Nelliette
1 links to fix, 1 were resolvable.

Looks good!
LacoR added a comment.Sep 3 2016, 9:16 AM

It seems, that something went wrong. Now the users, with he/she are correct (Redaktor/Redaktorka).

When I set to neutral, the usere space changes to "Užívateľ" see my user page. This description is now the Slovak translation, which was introduced with the change T143474

LacoR reopened this task as Open.Sep 3 2016, 9:16 AM

So we probably need to add neutral form to the $wgExtraGenderNamespaces array too.

I'll check that for this evening SWAT, deployment will be around 1:15 CEST.

Change 308901 had a related patch set uploaded (by Dereckson):
Restore Redaktor namespace on sk.wikipedia

https://gerrit.wikimedia.org/r/308901

Change 308901 merged by jenkins-bot:
Restore Redaktor namespace on sk.wikipedia

https://gerrit.wikimedia.org/r/308901

Change 308902 had a related patch set uploaded (by Dereckson):
Set User namespace aliases on sk.wikipedia

https://gerrit.wikimedia.org/r/308902

Change 308902 merged by jenkins-bot:
Set User namespace aliases on sk.wikipedia

https://gerrit.wikimedia.org/r/308902

Mentioned in SAL [2016-09-06T23:47:02Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Fix User namespace localisation for sk.wikipedia (T143472) (duration: 00m 47s)

@LacoR That has been deployed and seems to work correctly.

Do you confirm all looks good to you?

Mentioned in SAL [2016-09-06T23:52:53Z] <Dereckson> Ran namespaceDupes maintenance script on skwiki (0 pages to fix, 1 links to fix, fixed) (T143472)

Terbium
$ mwscript namespaceDupes.php skwiki --fix
0 pages to fix, 0 were resolvable.

pagelinks from=337181 ns=0 dbk=Redaktorka:nelliette -> Redaktorka:Nelliette
1 links to fix, 1 were resolvable.

Looks good!
LacoR added a comment.Sep 7 2016, 11:57 AM

@Dereckson It seems it works ok. Thanks for the help

You're welcome.

Dereckson closed this task as Resolved.Oct 6 2016, 11:16 AM