Page MenuHomePhabricator

UploadWizard tests fail on the new ResourcesTest::testMissingMessages() due to loading messages from WikimediaMessages
Closed, ResolvedPublic

Description

UploadWizard tests fail on the new messages structure test ResourcesTest::testMissingMessages() (39a00e2e) due to loading messages from WikimediaMessages. Example failing change (that should be passing): https://gerrit.wikimedia.org/r/305272https://integration.wikimedia.org/ci/job/mwext-testextension-hhvm/21204/console

The messages are not actually used by the code in the default configuration, so this is not a bug; they are used in WMF's configuration though (and we can't easily make the list of loaded messages dynamic).

I think it's possible to specify somewhere in CI config that UploadWizard depends on WikimediaMessages, but I don't remember where. Please help :)

Event Timeline

Restricted Application added a project: Multimedia. · View Herald TranscriptAug 20 2016, 11:40 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 306011 had a related patch set uploaded (by Bartosz Dziewoński):
Specify a CI dependency of UploadWizard on WikimediaMessages

https://gerrit.wikimedia.org/r/306011

Restricted Application added a subscriber: Matanya. · View Herald TranscriptAug 22 2016, 4:27 PM

Change 306011 merged by jenkins-bot:
Specify a CI dependency of UploadWizard on WikimediaMessages

https://gerrit.wikimedia.org/r/306011

matmarex closed this task as Resolved.Aug 22 2016, 4:36 PM
matmarex claimed this task.
matmarex removed a project: Patch-For-Review.
matmarex added a subscriber: hashar.

Deployed by @hashar.