Page MenuHomePhabricator

Conditional hiding of password fields broken in signup form
Closed, ResolvedPublic

Description

Steps to reproduce

"Password" and "Confirm password" fields should disappear.

Event Timeline

Tgr created this task.Aug 25 2016, 2:35 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 25 2016, 2:35 AM
Tgr added a comment.Aug 25 2016, 2:37 AM

Caused by one of the changes going out this week, and hide-if was recently updated for OOUI but the signup form is still non-OOUI so presumably caused by 8910707.

Tgr triaged this task as High priority.Aug 25 2016, 2:37 AM
Tgr added a comment.EditedAug 25 2016, 3:54 AM

Also, help text has disappeared. Enwiki has "help me choose" after the username, mediawiki.org hasn't. The extra whitespace is there so I guess HTML is getting stripped?

Also, help text has disappeared. Enwiki has "help me choose" after the username, mediawiki.org hasn't. The extra whitespace is there so I guess HTML is getting stripped?

This is not a bug. This message seems to be intentionally disabled on mw.org – https://www.mediawiki.org/wiki/MediaWiki:Createacct-helpusername exists and is just   (it should probably be empty to avoid the extra whitespace, like on testwiki: https://test.wikipedia.org/wiki/MediaWiki:Wikimedia-createacct-helpusername).

(This message is overridden in the WikimediaMessages extension, and the magic there allows it to be customized under both of these names.)

Change 306616 had a related patch set uploaded (by Bartosz Dziewoński):
mw.htmlform: Don't refer to OO.ui if it might not be loaded

https://gerrit.wikimedia.org/r/306616

matmarex claimed this task.Aug 25 2016, 4:35 AM
Tgr added a comment.Aug 25 2016, 5:18 AM

(it should probably be empty to avoid the extra whitespace, like on testwiki: https://test.wikipedia.org/wiki/MediaWiki:Wikimedia-createacct-helpusername).

Thanks, that fixed it. The positioning of the help message seems off, but that wasn't broken by this train:

Change 306616 merged by jenkins-bot:
mw.htmlform: Don't refer to OO.ui if it might not be loaded

https://gerrit.wikimedia.org/r/306616

Change 306706 had a related patch set uploaded (by Bartosz Dziewoński):
mw.htmlform: Don't refer to OO.ui if it might not be loaded

https://gerrit.wikimedia.org/r/306706

Change 306706 merged by jenkins-bot:
mw.htmlform: Don't refer to OO.ui if it might not be loaded

https://gerrit.wikimedia.org/r/306706

Mentioned in SAL [2016-08-25T18:29:42Z] <thcipriani@tin> Synchronized php-1.28.0-wmf.16/resources/src/mediawiki/htmlform/hide-if.js: SWAT: [[gerrit:306706|mw.htmlform: Do not refer to OO.ui if it might not be loaded (T143850)]] (duration: 00m 49s)

The positioning of the help message seems off, but that wasn't broken by this train:

Filed T143923: "(help me choose)" link near the username field in the signup form looks out of place, I'll look into this too.

matmarex closed this task as Resolved.Aug 25 2016, 6:31 PM
matmarex removed a project: Patch-For-Review.

Fixed and deployed.