Don't block the user from continuing to work while a statement get's saved/published
Closed, InvalidPublic

Description

Fast UI makes websites fun to use. Amazon famously increased their sales by 1% by reduce pageloading time by 100ms.

On Wikidata the fact that I have to wait as a user for Wikidata to save a statement or publish a statement reduces the fun I'm having while editing. This is especially annoying when working with the primary sources tool, where the wait time removes the fun of .

Modern Ajax should allow Wikidata to work in a way where the user doesn't have to wait for the server to finish saving a statement to allow the user to continue working.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 25 2016, 12:59 PM
thiemowmde triaged this task as Low priority.Sep 5 2016, 3:09 PM
thiemowmde added a subscriber: thiemowmde.

I'm afraid I do not understand what this ticket is about. What you are describing is already possible. You can edit multiple details on an item page the same time, independent from each other. Under which circumstances does this not work? Is this a bug in the PrimarySources tool?

Please edit and clarify this tasks description. Please provide steps to reproduce.

Lydia_Pintscher moved this task from incoming to monitoring on the Wikidata board.Dec 22 2017, 4:55 PM
Lydia_Pintscher moved this task from incoming to monitoring on the Wikidata board.
Lydia_Pintscher moved this task from incoming to monitoring on the Wikidata board.
Hjfocs closed this task as Invalid.May 23 2018, 2:49 PM
Hjfocs moved this task from To do to Done on the Wikidata-primary-sources board.
Hjfocs added a subscriber: Hjfocs.

Duplicate of T148179