Page MenuHomePhabricator

puppet::self hosts now have two servers set
Closed, DeclinedPublic

Description

I just set up a brand new puppet:self host and it has two different conf resources:

ls

10-main.conf 10-self.conf

This means that puppet.conf is a bit crazy, defining two different [agent] sections and two different servers. Surely that wasn't the intent of https://gerrit.wikimedia.org/r/#/c/284852/ -- maybe it wasn't tested on new, stand-alone boxes?

Event Timeline

Andrew created this task.Aug 27 2016, 9:08 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 27 2016, 9:08 PM

I set up a couple of hosts in deployment-prep while that was cherry-picked on deployment-puppetmaster and everything appeared okay.

Or do you mean new servers that are their own puppetmaster?

mmodell reassigned this task from 20after4 to Andrew.Aug 28 2016, 1:34 AM
mmodell added subscribers: 20after4, mmodell.

@Andrew: puppet::self is very prone to race conditions and it needs to be completely refactored.

I don't know if this was caused by rOPUP8a4cc8790f45: Fix race in puppet::self (puppet.conf compilation) but feel free to revert that commit if you feel it is causing the issue. I can't revert it myself as I don't have +2 on ops/puppet.

Keep rOPUP8a4cc8790f ! Else we are back to T132689 which has was quite annoying.

role::puppet::self for puppet *clients* is doubly terrible. I'll spend next week getting rid of that across labs - see https://phabricator.wikimedia.org/T120159#2587726.

Andrew closed this task as Declined.Sep 1 2016, 6:56 PM

I guess I don't care about this for now.

They shouldn't anymore, I fixed 'em all on tuesday.