Page MenuHomePhabricator

(non-patrolled pages) don't appear as yellow in arwiki (class "not-patrolled" not set for <li>)
Closed, InvalidPublic

Description

as usually, the non-patrolled pages in "Special:Newpages"appear as yellow.

in Arwiki all non-patrolled don't appear in yellow background (link here)

I checked source & CSS of page (inspect), class".not-patrolled" not appear in <li>, I don't know why?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 28 2016, 5:17 PM
Aklapper renamed this task from (non-patrolled pages) don't appear as yellow in arwiki to (non-patrolled pages) don't appear as yellow in arwiki (class "not-patrolled" not set for <li>).Aug 29 2016, 9:00 AM
FShbib added a subscriber: FShbib.Aug 29 2016, 5:05 PM
Urbanecm closed this task as Invalid.Aug 20 2017, 4:53 PM
Urbanecm added a subscriber: Urbanecm.

Seems this is a very old task, the error (re)appeard at T173556. See the task for details!

zhuyifei1999 reopened this task as Open.Aug 20 2017, 7:53 PM
zhuyifei1999 added a subscriber: zhuyifei1999.

I don't think this task is the same as the other task, which is a regression from 7660fe1 and therefore should not have appeared till this month. If this error is no longer reproduceable after the fix for T173556 please close.

Restricted Application added a subscriber: alanajjar. · View Herald TranscriptFeb 27 2020, 10:40 AM
includes/specials/SpecialNewpages.php
if ( $this->patrollable( $result ) ) {
	$classes[] = 'not-patrolled';
}
includes/specials/SpecialNewpages.php
protected function patrollable( $result ) {
	return ( $this->getUser()->useNPPatrol() && !$result->rc_patrolled );
}
includes/user/User.php
public function useNPPatrol() {
	global $wgUseRCPatrol, $wgUseNPPatrol;
	return (
		( $wgUseRCPatrol || $wgUseNPPatrol )
			&& ( $this->isAllowedAny( 'patrol', 'patrolmarks' ) )
	);
}

UseNPPatrol is enabled in arwiki and per Special:ListGroupRights only sysops have patrol. I couldn't verify this since I am not one on arwiki.

UseNPPatrol is enabled in arwiki and per Special:ListGroupRights only sysops have patrol. I couldn't verify this since I am not one on arwiki.

I can verify that non-patrolled pages in "Special:Newpages" appear as yellow for sysops.
So, we'd change (Patrol) to (autoreview) on above .php, as arwiki community want this yellow to appear for:

  • Autoreview flag
  • Editor flag
  • Reviewer flag
  • Sysop flag

But I see that we'd also talk about (Patrol) part, that it'd be enabled also on "Editor flag" not only "sysop flag".

autoreview is part of MediaWiki-extensions-FlaggedRevs, so this cannot be done. However, you can ask for granting patrol or patrolmarks for these groups. Please, create a new subtask (with Wikimedia-Site-requests) where you request which right should be granted to which groups on arwiki and demonstrate the community consensus on this.

autoreview is part of MediaWiki-extensions-FlaggedRevs, so this cannot be done. However, you can ask for granting patrol or patrolmarks for these groups. Please, create a new subtask (with Wikimedia-Site-requests) where you request which right should be granted to which groups on arwiki and demonstrate the community consensus on this.

Can you please demonstrate the difference between patrol and patrolmarks? then we can close this task and I'll ask for community consensus on arwiki then back to phab again.

"right-patrol": "Mark others' edits as patrolled"
"right-patrolmarks": "View recent changes patrol marks"

Users with patrolmarks will only see ! / yellow color but unlike patrol cannot mark as patrolled.

Users with patrolmarks will only see ! / yellow color but unlike patrol cannot mark as patrolled.

Thanks. Now the community discussion started to unable patrol on "editor" flag. So I'll open new ticket again after discussion finished.

alanajjar closed this task as Invalid.Jun 12 2020, 11:46 AM

Thank you @matej_suchanek for your investigation!

So I'll open new ticket again after discussion finished.

Opened T257106.
Thanks all