Page MenuHomePhabricator

Redundant results in ORES review tool
Closed, ResolvedPublic

Event Timeline

Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptAug 29 2016, 7:23 PM
Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes, Aklapper. · View Herald Transcript
Ladsgroup renamed this task from Redandat results in ORES review tool to Redundant results in ORES review tool.Aug 29 2016, 8:59 PM

enwiki, nlwiki, and fawiki are clean now. Working on wikidata and other wikis

All wikis are clean now. Then I need to figure it out why it shows duplicate rows.

Ladsgroup lowered the priority of this task from Unbreak Now! to High.Aug 29 2016, 9:09 PM

I was able to reproduce it, I'm getting a sense why it's happening but I'm not sure how I can fix it.

Change 307870 had a related patch set uploaded (by Ladsgroup):
Not including results when oresm_is_current = 0

https://gerrit.wikimedia.org/r/307870

Ladsgroup moved this task from Active to Review on the Scoring-platform-team (Current) board.

Can you explain what was wrong and how you fixed it?

Ladsgroup added a comment.EditedSep 1 2016, 8:06 AM

Okay,
Imagine we had this in ores_model

oresm_idoresm_nameoresm_versionoresm_is_current
1damaging0.0.10
2damaging0.0.21

and we have two scores for each model for every revision:

oresc_idoresc_revoresc_modeloresc_score...
123451510.06...
123461520.8...

In this case we would have two rows in user contribs or changes list query because we do LEFT JOIN on ores_model (using other types will lead to omitting cases when we don't have score which not desirable).

So I solved it by explicitly adding a where condition that oresm_is_current != 0.

It will all cases except when the oresc_model id doesn't exist in ores_model (which can happen due to T144195: Check model version replaces every time it runs.) but hopefully we won't see it again since the patch got merged.

Ladsgroup moved this task from Review to Done on the Scoring-platform-team (Current) board.

Change 307870 merged by jenkins-bot:
Not including results when oresm_is_current = 0

https://gerrit.wikimedia.org/r/307870

Halfak closed this task as Resolved.Sep 7 2016, 1:28 AM