Popup content is missing a scrollbar in some cases
Closed, ResolvedPublic3 Story Points

Description

It looks like when there is a long word/URL in an edit summary and it does not fit the popup, sometimes the scrollbar is missing.

E.g. on https://de.wikipedia.org/w/index.php?diff=121648836&oldid=99344045&title=Wikipedia%3AHauptseite&type=revision when hovering the newer revision, there is a scrollbar but when you scroll forward with an arrow, and hover this revision again, there is no scrollbar and contents of the popup are "clipped".

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 30 2016, 12:57 PM
WMDE-leszek set the point value for this task to 3.Aug 30 2016, 12:57 PM
WMDE-leszek triaged this task as "Normal" priority.
Addshore moved this task from Incoming to Revision Slider on the TCB-Team board.Sep 2 2016, 7:32 AM
WMDE-leszek edited the task description. (Show Details)Sep 8 2016, 8:40 AM
WMDE-leszek edited the task description. (Show Details)
Addshore moved this task from Incoming to Backlog on the Revision-Slider board.Sep 13 2016, 2:55 PM
Addshore added a subscriber: Addshore.

Easily reproducable

It looks like the OO.ui.PopupWidget is adding the overflow-x:scroll style to the incorrect div tag.
This style should be on the div with the "oo-ui-popupWidget-popup" class but instead is on the div with these classes "oo-ui-clippableElement-clippable oo-ui-popupWidget-body oo-ui-popupWidget-body-padded"

On a normal tooltip with a long summary this looks like:

When it should look like:

This isn't actually the issue described in the ticket, but fixing this will likely help.

Change 311638 had a related patch set uploaded (by Esanders):
Use word-break to avoid horizontal scrollbars inside popups

https://gerrit.wikimedia.org/r/311638

Change 311638 merged by jenkins-bot:
Use word-break to avoid horizontal scrollbars inside popups

https://gerrit.wikimedia.org/r/311638

Thanks @Esanders for the patch! It is a great improvement.

One more thing we could try to tweak is shown below, when a vertical scrollbar is shown it will cover parts of long strings in the popup.

Either vertical scrollbars could be switched off or some padding / shifting of text would be needed.

Lea_WMDE moved this task from Backlog to Doing on the Revision-Slider board.Sep 22 2016, 1:28 PM

Change 313203 had a related patch set uploaded (by Tobias Gritschacher):
Add fixed padding for scrollbar

https://gerrit.wikimedia.org/r/313203

Change 313203 merged by jenkins-bot:
Add fixed padding for scrollbar

https://gerrit.wikimedia.org/r/313203

Addshore closed this task as "Resolved".Oct 4 2016, 9:55 AM
Addshore claimed this task.
Tobi_WMDE_SW moved this task from Doing to Done on the Revision-Slider board.Oct 28 2016, 1:59 PM