Page MenuHomePhabricator

ZeroBanner / JSONConfig PHPUnit failure
Closed, ResolvedPublic2 Story Points

Description

22:20:56 1) JsonConfig\Tests\JCTitleParsingTest::testTitleParsing with data set #0 (false, null, false)
22:20:56 JsonConfig: Invalid $wgJsonConfigs['JsonZeroConfig']['remote']['url']: API URL is not set, and this config is not being stored locally [Called from JsonConfig\JCSingleton::parseConfiguration in /mnt/jenkins-workspace/workspace/mwext-testextension-php55/src/extensions/JsonConfig/includes/JCSingleton.php at line 143]
22:20:56
22:20:56 /mnt/jenkins-workspace/workspace/mwext-testextension-php55/src/includes/debug/MWDebug.php:311
22:20:56 /mnt/jenkins-workspace/workspace/mwext-testextension-php55/src/includes/debug/MWDebug.php:166
22:20:56 /mnt/jenkins-workspace/workspace/mwext-testextension-php55/src/includes/GlobalFunctions.php:1154
22:20:56 /mnt/jenkins-workspace/workspace/mwext-testextension-php55/src/extensions/JsonConfig/includes/JCSingleton.php:143
22:20:56 /mnt/jenkins-workspace/workspace/mwext-testextension-php55/src/extensions/JsonConfig/includes/JCSingleton.php:70
22:20:56 /mnt/jenkins-workspace/workspace/mwext-testextension-php55/src/extensions/JsonConfig/includes/JCSingleton.php:377
22:20:56 /mnt/jenkins-workspace/workspace/mwext-testextension-php55/src/extensions/JsonConfig/tests/phpunit/JCTitleParsingTest.php:49
22:20:56 /mnt/jenkins-workspace/workspace/mwext-testextension-php55/src/tests/phpunit/MediaWikiTestCase.php:389
22:20:56
22:20:56 FAILURES!
22:20:56 Tests: 2726, Assertions: 15704, Errors: 1, Skipped: 2, Risky: 1.
22:20:56 Build step 'Execute shell' marked build as failure
22:20:57 Recording test results
22:20:57 [PostBuildScript] - Execution post build scripts.
22:20:57 [mwext-testextension-php55] $ /bin/bash -xe /tmp/hudson6545938632947816971.sh
22:20:57 + /srv/deployment/integration/slave-scripts/bin/mw-teardown-mysql.sh
22:20:57 Archiving artifacts
22:20:57 Finished: FAILURE

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 31 2016, 12:27 AM

@Jdlrobson - what does this mean?

Hi @olga it just means we can't merge any code to that repo as a test is failing. It is also an indication that something may be broken in the zero extension that needs investigation/fixing.

We'll have a look at this in triage, seems important

MBinder_WMF triaged this task as High priority.Aug 31 2016, 5:19 PM
MBinder_WMF set the point value for this task to 2.
MBinder_WMF moved this task from Needs Analysis to 2016-17 Q1 on the Readers-Web-Backlog board.

I've also written T144412 so we can catch these issues in future via MobileFrontend.

Yurik added a subscriber: Yurik.Aug 31 2016, 5:50 PM

The settings are documented on mediawiki's extension page.

I will see if the unit tests in jsonconfig are correctly set up

Jdlrobson renamed this task from ZeroBanner PHPUnit failure to ZeroBanner / JSONConfig PHPUnit failure.Aug 31 2016, 5:51 PM

Change 304306 had a related patch set uploaded (by Reedy):
Convert JsonConfigModels and JsonConfigs to attributes

https://gerrit.wikimedia.org/r/304306

The above patch fixes this and looks like a good improvement (moving away from globals). @Yurik could you take a pass at that?

Change 304306 merged by jenkins-bot:
Convert JsonConfigModels and JsonConfigs to attributes

https://gerrit.wikimedia.org/r/304306

Jdlrobson closed this task as Resolved.Aug 31 2016, 7:59 PM
Jdlrobson claimed this task.

I can confirm this error is no longer showing up in Zero and patches are merging again.

Change 308094 had a related patch set uploaded (by Jdlrobson):
Convert JsonConfigModels and JsonConfigs to attributes

https://gerrit.wikimedia.org/r/308094

Change 308094 abandoned by Jdlrobson:
Convert JsonConfigModels and JsonConfigs to attributes

https://gerrit.wikimedia.org/r/308094