Page MenuHomePhabricator

Regression: Ability to comment on phame posts not working
Closed, ResolvedPublic

Description

After a recent update it is no longer possible to comment on Phame blog posts.

Event Timeline

Restricted Application added subscribers: TerraCodes, Aklapper. · View Herald TranscriptAug 31 2016, 5:58 AM
Peachey88 added a subscriber: Peachey88.

We did, I think this may have been regression after a phabricator update (I thought there was a task open about this but I can't find it.

Peachey88 renamed this task from Phabricator blog posts should allow comments to Regression: Ability to comment on phame posts not working.Aug 31 2016, 7:32 AM
Paladox added a subscriber: Paladox.Sep 3 2016, 2:06 PM

This looks like it was caused by https://github.com/wikimedia/phabricator/commit/15f9e0f6ea2fc55fbcb6f22229c24a3f34e7cf53

Can we report this upstream please?

Since only admins can write comments not any normal user.

Looks like there is a similar task upstream https://secure.phabricator.com/T11584 but not sure if it is related to our problem.

Testing on phab-01 which is using a newer phabricator version shows the comment box, I haven't tested weather writing a comment should work.

Lets see what happends when we upgrade weather that fixes things. If not then it has to be permissions on phame.

I tested it at upstream-phabricator. It seems like you need to be able to edit a post, to comment there.

Paladox added a comment.EditedSep 4 2016, 12:00 AM

@Luke081515 Oh I guess this needs reporting upstream so that commenting as a separate permission please?

Luke081515 moved this task from To Triage to Upstream on the Phabricator board.Sep 4 2016, 1:05 AM
Luke081515 edited projects, added Phabricator (Upstream); removed Phabricator.
Restricted Application added a project: Upstream. · View Herald TranscriptSep 4 2016, 1:05 AM

apparently without much discussion about its advantages and disadvantages compared to other communication channels

You may want to reopen T135689: Disable blogs on Phabricator, which was prematurely closed, to continue this discussion.

Aklapper triaged this task as Normal priority.Sep 5 2016, 7:30 PM

@Aklapper thanks for finding that :), I will now look at backporting it for if we do the phab update this week.

Nemo_bis removed a subscriber: Nemo_bis.Sep 5 2016, 8:27 PM
greg updated the task description. (Show Details)Sep 6 2016, 5:26 PM

Ok, this should be fixed now.

But now we need to create both

https://phab-01.wmflabs.org/transactions/editengine/phame.post/view/5/

and

https://phab-01.wmflabs.org/transactions/editengine/phame.blog/view/6/

since it looks like someone removed them from our phab install thus breaking everything.

(For the records, this is still an issue after today's update.)

Actually it is fixed in the update. It was because someone removed the forms that go with phame thus preventing any user from commenting.

I know why it is broken, it isent phabricator problem now.

The patch linked above should help now.

Could one of the Repository-Admins please import https://phab-01.wmflabs.org/transactions/editengine/phame.post/view/5/ into https://phabricator.wikimedia.org/transactions/editengine/phame.post/

please.

And set visibility to public.

Doint worry as the name suggests edit posts it wont actually allow any user to edit posts unleast they have the permissions set for them in the phame application.

Oh, I guess then the admin of phabricator.

Paladox closed this task as Resolved.Sep 8 2016, 8:37 PM
Paladox assigned this task to mmodell.

This is now resolved, you can now comment again. Fixed by @mmodell :)

Confirmed that it regressed. I cannot comment on any blog posts now.

I forgot what @mmodell did to fix this.

Paladox closed this task as Resolved.Jul 15 2017, 12:23 AM

Resolved again. Reported on #wikimedia-cloud but forgot that this task was reopened when i reported it there, then i remembered.

Zppix added a subscriber: Zppix.Jul 15 2017, 12:25 AM

Buttons are now grayed out for user w/o proper permissions.
See attached screenshot: