Page MenuHomePhabricator

Add ORES damaging scores to the ReviewStream feed and set simplified labels to aid their interpretation
Closed, DuplicatePublic

Description

Include an ORES good-faith score for every edit in the ERI feed (established in T143743). In addition, to make ORES scores more readily understandable, include a simplified system of flags to indicate discrete levels within the continuum of scores, as defined in T142785. The thresholds for the various discrete levels should be configurable, and should be configurable on a per-wiki basis. (It's likely we'll employ a more neutral way to describe this property than “Damaging” —E.g., “Possible Error”, “Needs Review”, etc.—but that should be addressed in the design process.)

CLOSING THIS AS IT IS A DUPLICATE OF T149734

Event Timeline

Catrope updated the task description. (Show Details)Sep 1 2016, 1:07 AM

In matter of data we can simply pull ores data around good faith contributions by enabling the goodfaith in ORES extension settings and then you can simply do a query like SELECT oresc_probability from ores_classification LEFT JOIN ores_model ON (oresc_model = oresm_id AND oresm_is_current = 1) WHERE oresm_name = 'goodfaith' AND oresc_rev = 1234.

In matter of threshold and making the discrete classification out of the spectrum You can choose them from recall, false positive rate or f-beta scores.

Also if you need a community to test out ERI, I can talk to Persian Wikipedia community and convince them to be beta testers of this tool.

Also if you need a community to test out ERI, I can talk to Persian Wikipedia community and convince them to be beta testers of this tool.

This task is for the machine-readable feed. We'll probably set that up on Labs first. Later when it is in production, the new feed still shouldn't impact existing users (though we will be looking for tools like Huggle to adopt it).

jmatazzoni renamed this task from Add ORES damaging scores to the ERI feed and set simplified labels to aid their interpretation to Add ORES damaging scores to the ReviewStream feed and set simplified labels to aid their interpretation.Sep 23 2016, 12:14 AM
jmatazzoni closed this task as Resolved.Jan 5 2017, 7:47 PM
jmatazzoni updated the task description. (Show Details)