Page MenuHomePhabricator

Support VisualEditor new wikitext feature without needing to setup any backend like parsoid
Closed, DeclinedPublic

Description

Steps to reproduce

  • No steps since this is a feature request.

Could we support the new wikitext feature without needing a backend like parsoid please?

This will make wikieditor truly deprecated in favour of VisualEditor.

And just to note, not everyone can have parsoid setup since some of us use a shared host which disallow things like that.

Plus VisualEditor seems more updated which I would like to use without needing to do anything else please?

I Know that the visual part needs parsoid but not the wikitext, it would be really great if you support this please.

Event Timeline

Paladox created this task.Sep 1 2016, 8:17 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 1 2016, 8:17 PM
Jdforrester-WMF closed this task as Declined.Sep 1 2016, 10:55 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

No.

Bah, sorry, tabbed poorly.

No. Most of the features rely on Parsoid/RESTbase to work, including in particular switching but also pretty-formatting templates' wikitext and so on.

Paladox reopened this task as Open.Sep 2 2016, 5:27 PM

But wikitext dosent need to use parsoid.

You say only switching and most of the other features.

But if were using wikitext then how can it be using parsoid since wikieditor dosent use parsoid and it works with wikitext?

We could support it so that users carnt switch to the visual side and can only use wikitext, and if they setup parsoid then visual editing should work.

What I'm talking about ^^ is for other wikis non Wikimedia wiki's.

I'm re opening as, ive replied to your question but this would be really great if we can do it.

Why can wikieditor do it and visualeditor carn't? I know the visual bit needs it and switching needs it. But I'm talking about allowing users who carnt install parsoid to use visualeditor but limited to wikitext and carnt switch.

Jdforrester-WMF triaged this task as Lowest priority.Sep 2 2016, 5:52 PM
Jdforrester-WMF added a project: Epic.

I Declined this because:

  • We will not work on this, even in the next two–three years.
  • It would likely take many hundreds of hours of work by experts in this area.
  • There are no such experts likely to want to work on it.
  • The complexity of this would require large amounts of our time just to review, assess, and merge any code someone else wrote. We probably wouldn't do so.

We can leave it open if you wish, but it seems disrespectful to pretend otherwise.

Deskana closed this task as Declined.Aug 30 2018, 12:28 PM
Deskana added a subscriber: Deskana.

This is such an absolutely monumental request—as in, many, many years of work for far more engineers than the Editing team currently has—that working on this task would possibly be the most inappropriate allocation of engineering resources that I've ever seen by several orders of magnitude. It's a theoretically good idea, but it's so unbelievably impractical that this is simply never going to happen. There's no point leaving this open.