Page MenuHomePhabricator

VE: can't edit <maplink>
Closed, ResolvedPublic1 Story Points

Description

Regression of T144003, a user can't edit <maplink> with VisualEditor. The link is recognized as a regular link.

See screenshot:


Event Timeline

JGirault created this task.Sep 1 2016, 10:52 PM
Restricted Application added a project: Discovery. · View Herald TranscriptSep 1 2016, 10:52 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 308300 had a related patch set uploaded (by Esanders):
Search all RDFa attributes when looking for type

https://gerrit.wikimedia.org/r/308300

Since an href was added to the link (for non JS support) it started matching as an MW external link, due to a bug in our matching logic (only looking at 'rel' for the special type, instead of 'typeof' and 'property' as well).

JGirault moved this task from Backlog to Needs review on the Maps-Sprint board.Sep 5 2016, 5:07 PM
JGirault assigned this task to Esanders.Sep 5 2016, 7:18 PM
Nux added a subscriber: Nux.Sep 6 2016, 3:57 PM

Change 308300 merged by jenkins-bot:
Search all RDFa attributes when looking for type

https://gerrit.wikimedia.org/r/308300

Change 308797 had a related patch set uploaded (by Yurik):
Search all RDFa attributes when looking for type

https://gerrit.wikimedia.org/r/308797

Change 308797 merged by jenkins-bot:
Search all RDFa attributes when looking for type

https://gerrit.wikimedia.org/r/308797

Change 308880 had a related patch set uploaded (by MaxSem):
Search all RDFa attributes when looking for type

https://gerrit.wikimedia.org/r/308880

Change 308880 merged by jenkins-bot:
Search all RDFa attributes when looking for type

https://gerrit.wikimedia.org/r/308880

Jdforrester-WMF closed this task as Resolved.Sep 7 2016, 9:07 PM
Jdforrester-WMF set the point value for this task to 1.Sep 9 2016, 6:45 PM