Page MenuHomePhabricator

Decide how to enable/disable unit conversions in flavors
Closed, ResolvedPublic

Description

Right now once T117031 is implemented if unit conversion is configured it is automatically used. We may want to have more fine-grained configuration, i.e. some option for disabling/enabling it, accounting for PRODUCE_NORMALIZED_VALUES and maybe other configuration values.

Details

Related Gerrit Patches:
mediawiki/extensions/Wikibase : masterUse flavor flags to configure builder

Related Objects

StatusAssignedTask
OpenNone
OpenNone
OpenNone
ResolvedSmalyshev
OpenNone
OpenNone
OpenNone
OpenNone
Opencscott
Resolvedhoo
OpenNone
OpenNone
OpenNone
Resolveddaniel
OpenNone
ResolvedLydia_Pintscher
Resolvedthiemowmde
Resolveddaniel
OpenNone
StalledNone
StalledNone
ResolvedSmalyshev
OpenNone
OpenNone
ResolvedSmalyshev
ResolvedSmalyshev
ResolvedSmalyshev
InvalidNone
Resolveddaniel
ResolvedSmalyshev
OpenNone
ResolvedLydia_Pintscher
ResolvedLadsgroup
OpenNone
ResolvedLadsgroup

Event Timeline

Smalyshev created this task.Sep 5 2016, 8:26 PM

We probably need to configure rdf-builder-factory-callback for VT:quantity somehow depending on flavor flags. The problem is flavor flags are not accessible there and not passed to ValueSnakRdfBuilderFactory either, so we'd have to either add parameter or maybe modify $mode parameter to be more complex.

@daniel, any ideas on how to make it best?

Jc3s5h added a subscriber: Jc3s5h.Sep 5 2016, 8:58 PM

@Smalyshev maybe we can just pass the GENERATE_XXX flags as $mode, what do you think? The flags should cover the current information in $mode anyway.

Yes, this should be possible, though requires changing all code that uses $mode, but it's not too much right now. I'll look into it later.

Smalyshev renamed this task from Decide how to configure unit conversions to Decide how to enable/disable unit conversions in flavors.Sep 6 2016, 4:59 PM
Smalyshev claimed this task.Sep 6 2016, 6:13 PM

Change 309227 had a related patch set uploaded (by Smalyshev):
Use flavor flags to configure builder

https://gerrit.wikimedia.org/r/309227

Change 309227 merged by jenkins-bot:
Use flavor flags to configure builder

https://gerrit.wikimedia.org/r/309227

Smalyshev closed this task as Resolved.Sep 12 2016, 3:46 PM
Smalyshev moved this task from Backlog to Done on the Discovery-Wikidata-Query-Service-Sprint board.