Page MenuHomePhabricator

TypeError: this.options.quickList is null jquery.uls.lcd.js:319:9
Closed, ResolvedPublic

Description

As of wmf18 on all pages, whenever an input element gets the focus.

Caused by 3499b0a1b90351740c6a1c94a7f5a9446051b595.

Event Timeline

hoo created this task.Sep 6 2016, 10:38 PM
Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes, Aklapper. · View Herald TranscriptSep 6 2016, 10:38 PM

Change 308897 had a related patch set uploaded (by Hoo man):
Use an array for an empty quickList, not false

https://gerrit.wikimedia.org/r/308897

hoo claimed this task.Sep 6 2016, 11:27 PM
hoo added subscribers: santhosh, Nikerabbit, Amire80.

Change 308914 had a related patch set uploaded (by Catrope):
Revert "Update jquery.uls to a9dc11b"

https://gerrit.wikimedia.org/r/308914

Change 308915 had a related patch set uploaded (by Catrope):
Revert "Update jquery.uls to a9dc11b"

https://gerrit.wikimedia.org/r/308915

hoo added a comment.Sep 7 2016, 12:51 AM

Worked around by reverting the update on the branch.

Change 308914 merged by jenkins-bot:
Revert "Update jquery.uls to a9dc11b"

https://gerrit.wikimedia.org/r/308914

Deploying the revert commit above in the 11:00 PDT SWAT tomorrow (Wednesday Sep 7), because these errors massively break VisualEditor. Pressing enter to split paragraphs/list items is very breaky, as is tab to indent list items.

Change 308950 had a related patch set uploaded (by Amire80):
Update jquery.uls from upstream

https://gerrit.wikimedia.org/r/308950

Change 308897 abandoned by Hoo man:
Use an array for an empty quickList, not false/null

Reason:
Amir picked this up in https://gerrit.wikimedia.org/r/308950

https://gerrit.wikimedia.org/r/308897

Change 308950 merged by jenkins-bot:
Update jquery.uls from upstream

https://gerrit.wikimedia.org/r/308950

Change 308915 merged by jenkins-bot:
Revert "Update jquery.uls to a9dc11b"

https://gerrit.wikimedia.org/r/308915

Mentioned in SAL [2016-09-07T18:24:18Z] <thcipriani@tin> Synchronized php-1.28.0-wmf.18/extensions/UniversalLanguageSelector: SWAT: [[gerrit:308915|Revert "Update jquery.uls to a9dc11b" (T144871)]] (duration: 00m 47s)

Jdforrester-WMF closed this task as Resolved.Sep 7 2016, 8:06 PM

Change 309308 had a related patch set uploaded (by KartikMistry):
Update jquery.uls from upstream

https://gerrit.wikimedia.org/r/309308

Change 309308 merged by jenkins-bot:
Update jquery.uls from upstream

https://gerrit.wikimedia.org/r/309308