Page MenuHomePhabricator

After saving an article atop a redirect, sub continues to show "Redirect page"
Closed, InvalidPublic1 Estimated Story Points

Description

  1. Edit a redirect in VisualEditor.
  2. Remove the redirect from the advanced page options.
  3. Write some content and save it.

Actual:

The contentSub element still displays the "Redirect page" caption below the page heading, even though the user is now in Read mode and it is no longer a redirect.

Event Timeline

Krinkle created this task.Sep 7 2016, 1:41 AM
Restricted Application added a project: VisualEditor. · View Herald TranscriptSep 7 2016, 1:41 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Jdforrester-WMF triaged this task as Medium priority.Oct 4 2016, 7:27 PM
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.
Jdforrester-WMF set the point value for this task to 1.

I just tried this and couldn't reproduce the issue.

matmarex closed this task as Invalid.Mar 28 2017, 3:28 PM
matmarex added a subscriber: matmarex.

I can't reproduce this either. But there are other funny issues with the "Redirect page" subtitle, see T161614 and the (upcoming) patch there.