Page MenuHomePhabricator

Make browsertests pass on beta/ make stable
Closed, ResolvedPublic

Description

The browser tests on beta should be stable, so that they can be used to alert people in case of regressions: https://integration.wikimedia.org/ci/job/selenium-Wikibase/BROWSER=firefox,MEDIAWIKI_ENVIRONMENT=beta,PLATFORM=Linux,label=contintLabsSlave%20&&%20UbuntuTrusty/

This is even more important as it's not possible to subscribe to only failures of the test.wikidata.org browser tests right now (which I would like to have, for post-deploy checking).

Event Timeline

hoo created this task.Sep 7 2016, 2:15 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 7 2016, 2:15 AM
hoo added a subscriber: aude.

Since the same test set runs almost stable on test.wikidata.org I think this is a platform problem - beta being unstable or unavailable during the 2 hours the tests run.

One idea that was just coming to my mind - we could try running a larger test set every time we have a new build for https://gerrit.wikimedia.org/r/#/admin/projects/mediawiki/extensions/Wikidata directly on integration. Not sure entirely if that is possible.

hoo added a comment.Sep 7 2016, 12:29 PM

One idea that was just coming to my mind - we could try running a larger test set every time we have a new build for https://gerrit.wikimedia.org/r/#/admin/projects/mediawiki/extensions/Wikidata directly on integration. Not sure entirely if that is possible.

That sounds ok to me, especially if done post merge.

But still, there should be a way to subscribe people to the results of the tests on test.wikidata.org (and we need to make sure they run after the deploy and early enough so that we can actually fix things before our code hits Wikidata.org).

selenium-Wikibase job no longer exists. Can this be resolved?

hashar closed this task as Resolved.Dec 12 2019, 2:07 PM
hashar claimed this task.
hashar added a subscriber: hashar.

Those mediawiki-selenium ruby tests are gone.