Page MenuHomePhabricator

some VisualEditor edits add <noscript> tags with links to facebook
Closed, ResolvedPublic1 Story Points

Description

I noticed an odd pattern in the Hebrew Wikipedia: some visual edits add a <noscript> tag towards the end of the article's wiki syntax code, and inside the tag there's a URL to Facebook. Most of these edits are mobile, but at least one is a usual desktop VE edit.

I only found it in the Hebrew Wikipedia. I tried some other languages—English, French, German, Czech—and I couldn't find anything like that. It might be something special to Hebrew or to Israeli people, and I'm not sure what it could be. Input from CCed Israelis is welcome :)

Examples:

Event Timeline

Amire80 created this task.Sep 7 2016, 7:19 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 7 2016, 7:19 AM
IKhitron added a comment.EditedSep 7 2016, 9:33 AM

I checked some examples. It looks like it's always the same facebook address. Let me assume that the problem isn't VE, but the internet provider (like Rimon or NetFree), that adds this address as commercial or as bug.

DLynch added a subscriber: DLynch.Sep 8 2016, 4:36 PM

It looks like a tracking pixel, probably being auto-inserted by the provider into the API response which fetches the VE html (/api/rest_v1/page/html/PageName?redirect=false), since it looks very-like a regular HTML page.

Not sure if we actually want to cater to fixing this fairly-broken situation. Perhaps we could strip any elements which lack a parsoid ID when we import said API response?

DLynch added a comment.Sep 8 2016, 9:11 PM

Hm, I'm inclined to say that <noscript> is almost-certainly junk, but I could be overlooking something?

Change 309405 had a related patch set uploaded (by Jforrester):
ve.init.mw.Target: Drop <noscript> tags on serialisation

https://gerrit.wikimedia.org/r/309405

Jdforrester-WMF closed this task as Resolved.Sep 8 2016, 9:34 PM
Jdforrester-WMF claimed this task.
Jdforrester-WMF triaged this task as Normal priority.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.
Jdforrester-WMF set the point value for this task to 1.

Change 309405 merged by jenkins-bot:
ve.init.mw.Target: Drop <noscript> tags on serialisation

https://gerrit.wikimedia.org/r/309405

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMar 6 2018, 11:49 PM