Page MenuHomePhabricator

Gerrit in Microsoft Edge doesn't display the git commands in the download box
Closed, ResolvedPublic

Description

Steps to reproduce

Expected results

  • I expect the commands to be shown.

Actual results

  • No commands are shown expect from the two at the bottom which are download links and not git commands to download the patches.

Event Timeline

Paladox created this task.Sep 8 2016, 8:13 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 8 2016, 8:13 PM

Change 309385 had a related patch set uploaded (by Paladox):
Workaround a bug in gerrit on Microsoft Edge

https://gerrit.wikimedia.org/r/309385

Paladox triaged this task as High priority.Sep 8 2016, 8:14 PM

This affects users who use Microsoft Edge so setting as high priority.

tom29739 renamed this task from Microsoft Edge in gerrit dosent display the git commands in the download box to Gerrit in Microsoft Edge doesn't display the git commands in the download box.Sep 9 2016, 12:26 AM
tom29739 updated the task description. (Show Details)
Paladox moved this task from Backlog to Reported Upstream on the Upstream board.
Aklapper lowered the priority of this task from High to Low.Sep 9 2016, 10:40 AM

I don't see a patch submitted in upstream, but a patch in Wikimedia Gerrit only? Why?

This affects users who use Microsoft Edge so setting as high priority.

@Paladox: "affects users who use Microsoft Edge" (or "affects people living in some city in some country") is no logical argument related to a setting describing urgency, and the functionality does not seem to be the most critical one either. Please refrain from setting priorities until there is a clearer understanding what they are supposed to mean. Thanks! (No "Ok" reply needed here.)

The reason I only have a patch on our gerrit is because it is a workaround and not a fix. But isent a browser that users use on windows 10 important enough instead of setting it to low priority.

What happends if a user uses Microsoft edge but carnt clone because it dosent display it properly.

Why did you set it to low priority, I doint see this as low priority.

Please explain what you think is high priority, low priority since browsers not displaying properly should be counted as high priority.

Not everyone uses chrome or firefox.

There is always git review -d 123456 as a workaround, no matter which browser users use.

See this page for Priority level explanations. (Any debating of the meaning of those levels is off-topic for this task.)

Dzahn added a subscriber: Dzahn.Sep 13 2016, 4:18 PM

@Paladox can you show the difference on the labs instance?

Change 309385 merged by Dzahn:
gerrit: workaround a CSS bug with Microsoft Edge

https://gerrit.wikimedia.org/r/309385

Dzahn closed this task as Resolved.Sep 13 2016, 5:43 PM
Dzahn claimed this task.
Paladox reopened this task as Open.Sep 17 2016, 9:24 PM

Re opening as the workaround will only work for logged in users not logged out users since it will only show the anon http selection and not http and ssh.

Aklapper removed Dzahn as the assignee of this task.Sep 18 2016, 6:39 PM

I belive this may be a bug in Microsoft Edge, I've reported it to them so hopefully it will be fixed soon. I'm not 100% sure it is a bug in Edge but anyways ive reported it. This task should stay open until it is fixed in gerrit or edge.

According to them the bug does not exist currently in the public released version, ie the annerversery update but does in the windows insider build, they say there is a fix internally but I doint know if it is now in the public release of windows insider build since the last response was September 20 2016.

Paladox closed this task as Resolved.Oct 8 2016, 7:01 PM
Paladox claimed this task.

This was broken on insider releases when they first released new build in mid agust this doesn't affect production versions.

This is now fixed in build 14942. I've confirmed it is fixed and closing as resolved now :)