Page MenuHomePhabricator

Headings occasionally serialised as <h2> elements rather than \n\n== Foo ==\n in Parsoid
Closed, ResolvedPublic1 Story Points

Description

There is two examples of edits taged as done with VE, where <h2> tags have been introduced:
*The Island, seuls au monde
*Chloé Sauvourel

Based on that feedback.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 9 2016, 4:30 PM
Jdforrester-WMF renamed this task from <h2> elements introduced by VE to Headings occassionally serialised as <h2> elements rather than \n\n== Foo ==\n in Parsoid.Sep 13 2016, 7:20 PM
Jdforrester-WMF added a project: Parsoid.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

No repro, sadly.

I wonder if this is related to T134593: Intermittent corruptions on saves, likely related to data-parsoid mis-matches.

I had mentioned there that we could probably add some heuristics to detect these data-parsoid mismatch scenarios ... maybe worth reviving that idea.

@Jdforrester-WMF, @Trizek-WMF, it would be useful to ask those editors who reported these bugs if they did any copy-paste of wikitext.

I'm contacting the first one. That account doesn't have a lot of activity.
The second one is an IP and I can't expect an answer.

@NicoV may have noticed some other cases which may have been done by a more active user.

Elitre renamed this task from Headings occassionally serialised as <h2> elements rather than \n\n== Foo ==\n in Parsoid to Headings occasionally serialised as <h2> elements rather than \n\n== Foo ==\n in Parsoid.Sep 21 2016, 7:46 AM
Elitre updated the task description. (Show Details)
Elitre added a subscriber: Elitre.
Nnvu added a subscriber: Nnvu.Sep 21 2016, 1:08 PM
Nnvu added a comment.Sep 21 2016, 4:57 PM

I asked some of the users in itwiki if they remember how they have done the edits that added the <h2> tag. If the answer me with useful infos, I report them.

Nnvu added a comment.EditedSep 21 2016, 5:45 PM

A user told me he had done a copy-paste from a page in VE edit mode to another one in VE edit mode. Unfortunately, his edit was done on June, 21st, so the system has been updated on itwiki and I can't reproduce the issue.

ssastry moved this task from Backlog to Non-Parsoid Tasks on the Parsoid board.Sep 26 2016, 3:58 PM
Jdforrester-WMF changed the task status from Open to Stalled.Oct 14 2016, 12:57 AM
Jdforrester-WMF triaged this task as Normal priority.
Jdforrester-WMF set the point value for this task to 1.

It's possible that this will now be fixed by T146054: VE should strip element ids from HTML that it generates when wikitext is pasted (which will go into production from 25 October). Consequently, let's come back to this in a month and see if it's re-occurred after that.

Jdforrester-WMF closed this task as Resolved.Nov 17 2016, 7:06 PM
Jdforrester-WMF assigned this task to AlexMonk-WMF.

OK, this looks like that did fix it. (Yay.)