Page MenuHomePhabricator

Release 5.2.0 (939)
Closed, ResolvedPublic

Description

Release version: 5.2.0
Release tag: releases/5.2.0.939
Release SHA1: 764fd3ea1c0b611c8608e0eb3f0759a0488dffa3
App Store Submission Date: 9/9/2016, new binary resubmit on 9/12/2016
App Store Approval Date: 9/12/2016
App Store Release Date: 9/13/2016
Regression Testing URL:


  • Update contributors list
  • Update "Licenses" section (e.g. new libraries, fonts, images, etc.) See note below
  • Point current status at this card
  • Submit Beta on iTunes Connect for external testing review
  • Submit RC on iTunes Connect for App Store review with automatic set to midnight on 9/13, per Apple instructions
  • Distribute RC for internal testing on iTunes Connect
  • Distribute RC to TSG
  • Post to mobile-l when Beta is approved for external testing
  • Draft What's New,
  • Update "What’s New" on iTunes Connect
  • Review App Store description, and determine if we need to update
  • Draft App Store Description
  • Upload new screenshots & app icons to iTunes Connect (if needed)
  • Perform upgrade smoke tests from current App Store version to new "Wikipedia Mobile" release candidate
  • Review Regression testing report, triage bugs, and identify any blockers
  • Verify Crash report received from TSG in Hockey App
  • Release to App Store (NOT on a Friday!)
  • Update central mobile release history once released
  • Update HockeyApp console to mark build as released once released
  • Notify to post on Twitter and Facebook
  • Post on mobile-l

Event Timeline

JMinor created this task.Sep 9 2016, 9:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 9 2016, 9:02 PM
JMinor triaged this task as High priority.Sep 9 2016, 9:03 PM
JMinor moved this task from Tasks from Product Backlog to Doing on the iOS-app-v5.2.0-Honey board.
JMinor updated the task description. (Show Details)Sep 9 2016, 10:12 PM
JMinor renamed this task from Release 5.2.0 (TBD) to Release 5.2.0 (939).Sep 12 2016, 10:09 PM
JMinor updated the task description. (Show Details)

@JoeWalsh @Fjalapeno there doesn't appear to be a github tag for this version?

Josve05a updated the task description. (Show Details)Sep 15 2016, 10:38 AM
JMinor updated the task description. (Show Details)Sep 15 2016, 9:08 PM
JMinor updated the task description. (Show Details)Sep 15 2016, 9:15 PM

OOh looks like we broke our automated "libraries list builder". Good catch!

Created T145822 to fix that for next version.

JMinor closed this task as Resolved.Sep 20 2016, 7:18 PM