Page MenuHomePhabricator

Move footer changes to stable
Closed, ResolvedPublic3 Story Points

Description

Story
As a reader, I want the footer in my articles to be easy to use, so that I can choose what to do next on the page

Description
Move footer changes from T141002: Align elements in article footer on beta to stable and deploy to all wikis

tech

  • Keep the stable version CSS until the cache has cleared (1 week)
  • Remove after cached HTML has disappeared

Testing criteria

Ensure footer displays as in the mockups below for the following cases:

Basic footer without related pages (non-beta users):

  1. Go to https://en.m.wikipedia.org/wiki/Gold_dollar on any device
  2. Ensure beta is "off"
  3. Confirm footer displays as in the mockup below

Footer with related pages:

  1. Go to https://bg.m.wikipedia.org/wiki/%D0%91%D0%B5%D0%BB%D0%B3%D0%B8%D1%8F
  2. Ensure beta is "off"
  3. Confirm footer displays as in mockup below

Note: wikipedia wordmark does not have to appear for non-English wikipedia

Footer for recently edited page:

  1. Go to https://en.m.wikipedia.org/wiki/Gold_dollar
  2. Ensure beta is "off"
  3. Confirm footer displays green version of "last edited" banner

Note: related pages should not appear

Desktop layout for the footer:

  1. Go to https://bg.m.wikipedia.org/wiki/%D0%91%D0%B5%D0%BB%D0%B3%D0%B8%D1%8F on any tablet, any browser
  2. Change orientation of tablet to landscape
  3. Ensure related pages appear horizontal (vs. vertically stacked)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 12 2016, 7:29 PM

@Jhernandez - to add acceptance criteria around what to do with old footer code

Jhernandez updated the task description. (Show Details)Sep 14 2016, 4:41 PM
MBinder_WMF set the point value for this task to 3.Sep 19 2016, 4:31 PM
jhobs moved this task from To Do to Doing on the Reading-Web-Sprint-82-Xpect-Rspec board.
ovasileva updated the task description. (Show Details)Sep 29 2016, 11:42 AM

Change 313426 had a related patch set uploaded (by Jhobs):
Push footerV2 to stable

https://gerrit.wikimedia.org/r/313426

Hi @jhobs replying here rather than Gerrit. It happens on every page view in stable. The only thing that might be stopping you from seeing this at a guess is T113095

Am puzzled why you can't reproduce this :/

Basically the last modified bar is not inside the footer element.

</div></div><div class="printfooter">
Retrieved from "<a dir="ltr" href="http://localhost:8888/w/index.php?title=Headings_are_broke&amp;oldid=1605">http://localhost:8888/w/index.php?title=Headings_are_broke&amp;oldid=1605</a>"</div>
</div><div class="post-content" id="page-secondary-actions"></div><div class="last-modified-bar view-border-box footer-element">
	<div class="content">
		<div class="last-modifier-tagline truncated-text mw-ui-icon mw-ui-icon-before mw-ui-icon-clock-gray ">
			<div class="mw-ui-icon mw-ui-icon-element mw-ui-icon-arrow-gray mw-ui-icon-small indicator"></div><a href="/w/index.php/Special:History/Headings_are_broke"
				data-user-name="Jdlrobson"
				data-user-gender="unknown"
				data-timestamp="1471477163">
				Last edited on 18 August 2016, at 01:39
			</a>
		</div>
	</div>
</div>
		</div>
		
<footer >

<div class="post-content footer-content">
	<h2></h2>
	<div class="license"></div>

At a casual glance
includes/skins/MinervaTemplateBeta.php
has a line

'lastmodified' => $this->getHistoryLinkHtml( $data ),

I suspect this needs to be moved to stable channel and made dependent on isFooterV2

It should have nothing to do with hlist-separated

In case it wasn't obvious I've commenting on stable when wgMinervaUseFooterV2=true since that is the goal of the task.

jhobs added a comment.EditedSep 30 2016, 9:20 PM

I've uploaded a new patch that solves your issue @Jdlrobson, but there are still issues with it (see screenshots below). I've been banging my head against the wall trying to figure out what's wrong since the second (larger) "devwiki" appears to be set by the 'footerlinks' field in $data in MinervaTemplate.php::getFooterTemplateData(), which theoretically shouldn't differ between stable and beta. And if it does, I can't figure out where it's set (render() is called with $this->data, which appears to come from BaseTemplate in core).

Local wiki, beta (expected):

Local wiki, stable (actual). Note duplicate wiki name and messed up links:

Jdlrobson removed a project: Patch-For-Review.

We'll need to SWAT the config change when the rest of the dependencies are resolved so moving back to TODO.

Change 313426 merged by jenkins-bot:
Prepare footerV2 for stable

https://gerrit.wikimedia.org/r/313426

We'll need to SWAT the config change when the rest of the dependencies are resolved so moving back to TODO.

It's unclear if this task included deploying FooterV2 to any production wikis, as there's not much acceptance criteria. I thought it was purely a technical task about moving the code, which would make it Ready for Signoff.

@ovasileva can you clarify whether this task should include deployment of the V2 Footer to wikis or simply handle the movement of code from beta to stable to prepare for future deployment(s)? If the former, please add a deployment plan (which wikis if not all, when, etc.). If the latter, please move to Ready for Signoff and an engineer can sign off.

Change 313891 had a related patch set uploaded (by Jhobs):
Fix content being added to v1 footer via .hlist-separated

https://gerrit.wikimedia.org/r/313891

Change 313891 merged by jenkins-bot:
Fix content being added to v1 footer via .hlist-separated

https://gerrit.wikimedia.org/r/313891

Change 313898 had a related patch set uploaded (by Jdlrobson):
Push footer version 2 to stable

https://gerrit.wikimedia.org/r/313898

@jhobs - updating description, this should include actual deployment, sorry for the confusion

ovasileva updated the task description. (Show Details)Oct 4 2016, 12:29 PM
ovasileva updated the task description. (Show Details)Oct 4 2016, 4:20 PM

Change 313898 merged by jenkins-bot:
Push footer version 2 to stable

https://gerrit.wikimedia.org/r/313898

Mentioned in SAL (#wikimedia-operations) [2016-10-06T23:02:48Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Enable footer v2 on Minerva for all wikis (T145442) (duration: 00m 50s)

ovasileva updated the task description. (Show Details)Oct 12 2016, 8:51 AM

From recreating the Testing Criteria as described by @ovasileva the results appear to be working good. I've attached a few screencaps showing what they looked like on my end -

Desktop layout for the footer (iPad Air 2, iOS 10.0.1, Safari)
Footer with related pages (Samsung Galaxy Express SIII, Android 6.0.1, Chrome)
Basic footer without related pages [non-beta](iPhone, iOS 9.3.5, Safari) - shows green version of banner

ovasileva closed this task as Resolved.Oct 13 2016, 8:58 AM