Page MenuHomePhabricator

Preview with <maplink> does not work
Closed, ResolvedPublic

Description

By creating a page from scratch and adding <maplink> entries, it is not possible to preview the page with the correct maplink unless saved.
As the creation of a more complicated maplink can be tedious, it might need a couple of edit-save-check cycles until the maplink is right.

This breaks expectation about preview.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 14 2016, 8:34 AM
Gehel added a subscriber: Yurik.Sep 14 2016, 8:55 AM
JGirault added subscribers: MaxSem, JGirault.EditedSep 14 2016, 3:37 PM

@MaxSem any ideas?

Here's the problem:
When editing a <maplink>, going to edit preview, and clicking on the maplink, the Kartographer code expects to make an API call to fetch the maplink's data... and the server logically returns null (nothing was saved, the article may not even exist in the database yet).

The problem is similar to the data missing when the map is just saved in VisualEditor. It needs a hard refresh to be able to download the map data and display the correct map. See T127927

MaxSem claimed this task.Sep 14 2016, 5:54 PM

Change 310631 had a related patch set uploaded (by MaxSem):
Always serve all the data on preview

https://gerrit.wikimedia.org/r/310631

Change 310631 merged by jenkins-bot:
Always serve all the data on preview

https://gerrit.wikimedia.org/r/310631

Change 310681 had a related patch set uploaded (by Yurik):
Always serve all the data on preview

https://gerrit.wikimedia.org/r/310681

Change 310681 merged by jenkins-bot:
Always serve all the data on preview

https://gerrit.wikimedia.org/r/310681

MaxSem closed this task as Resolved.Sep 14 2016, 11:11 PM

Mentioned in SAL (#wikimedia-operations) [2016-09-14T23:43:53Z] <dereckson@tin> Synchronized php-1.28.0-wmf.19/extensions/Kartographer/includes/Tag/TagHandler.php: Always serve all the data on preview (T145615, 1/2) (duration: 00m 47s)

Mentioned in SAL (#wikimedia-operations) [2016-09-14T23:44:43Z] <dereckson@tin> Synchronized php-1.28.0-wmf.19/extensions/Kartographer/tests/phpunit/KartographerTest.php: Always serve all the data on preview (T145615, 2/2, no-op part) (duration: 00m 50s)

Restricted Application added a project: Discovery. · View Herald TranscriptSep 16 2016, 7:25 AM