Page MenuHomePhabricator

EmbedPlayer only shows a blank page on Commons for video files
Closed, ResolvedPublic

Description

Hi, when opening https://commons.wikimedia.org/wiki/File:01_Editieren_und_Anmelden.ogg?embedplayer=yes the video does not load here (tested with Chromium and Firefox). What's wrong? Starting it from the file page works for me.

Best,
Martin

Event Timeline

Restricted Application added subscribers: Poyekhali, Aklapper. · View Herald TranscriptSep 20 2016, 8:14 AM
Aklapper renamed this task from EmbedPlayer does not load on Commons to EmbedPlayer only shows a blank page on Commons for video files.Sep 20 2016, 1:27 PM
Aklapper added a project: Regression.

Hi the only one that shows blank to me is https://commons.wikimedia.org/wiki/File:01_Editieren_und_Anmelden.ogg?embedplayer=yes if I go to https://commons.wikimedia.org/wiki/File:01_Editieren_und_Anmelden.ogg

It works

I'm using iPhone 6 Plus iOS 10 safari

Also @Aklapper your links work for me and they show.

TheDJ added a subscriber: TheDJ.Sep 20 2016, 10:14 PM

Because of embedPlayerIframe style module, which contains:

.mediaContainer {
    visibility: hidden;
}

I suspect that the order in which the stylesheets or JS are loaded recently changed due to MediaWiki-ResourceLoader changes and that this has caused an unintended side effect...

Or maybe it was broken before, and we never noticed.... something like that.

brion added a subscriber: brion.Sep 20 2016, 10:17 PM

Yeah I think this is new with the resourceloader tweaks or other recent changes, something went awry. I'm taking a peek...

@TheDJ looks like this got added in 41fda1ba7f4fc139318a9743eb1a84b9b890e6d8 ... I must not have tested it properly in mwembed mode or else it was interacting differently before. Do you remember why the visibility:hidden was there?

ah wait it was previously inline, changed by the transform.

Change 311852 had a related patch set uploaded (by Brion VIBBER):
Fix regression that embedded video player didn't work

https://gerrit.wikimedia.org/r/311852

Change 311852 merged by jenkins-bot:
Fix regression that embedded video player didn't work

https://gerrit.wikimedia.org/r/311852

Change 311857 had a related patch set uploaded (by Brion VIBBER):
Fix regression that embedded video player didn't work

https://gerrit.wikimedia.org/r/311857

Change 311858 had a related patch set uploaded (by Brion VIBBER):
Fix regression that embedded video player didn't work

https://gerrit.wikimedia.org/r/311858

Change 311857 merged by jenkins-bot:
Fix regression that embedded video player didn't work

https://gerrit.wikimedia.org/r/311857

Change 311858 merged by jenkins-bot:
Fix regression that embedded video player didn't work

https://gerrit.wikimedia.org/r/311858

brion closed this task as Resolved.Sep 20 2016, 11:29 PM
brion claimed this task.

Merged fix to master; backported for SWAT deployment. Should be live shortly or already (cached pages may still be affected for a bit).

TheDJ added a comment.EditedSep 21 2016, 1:01 PM

It's initially hidden, because the resource's thumbnail is initially shown, while we wait for the JS to load the player.

Since on videojs, we have the poster attribute, we don't need that for that case (it hides that #bgimage using css immediately I think...). I probably just forgot to update the mwembed js fragment that flipped the visibility flag (or missed adding it to the commit or something)..

Change 312055 had a related patch set uploaded (by Paladox):
Fix regression that embedded video player didn't work

https://gerrit.wikimedia.org/r/312055

Change 312055 merged by jenkins-bot:
Fix regression that embedded video player didn't work

https://gerrit.wikimedia.org/r/312055