Page MenuHomePhabricator

UploadWizard warns of properly filling gin all the fields; isn't clear which fields it wants
Closed, ResolvedPublic

Description

When using the UploadWizard on Wikimedia Commons I received a warning dialog when interacting with the final "Next" before uploading the file.

I filled out the three required fields (Title, Description, and Date) and then pressed "Next"

It is hard to see that there is now a small indicator that the "Categories" field is recommended. The Warning dialog overlays most of the form (and fades it out). The appearance of the field recommendation happens at the same time as the dialog appearing (where my focus is at), and the recommendation itself is not distinguished from other field labels (set in the same font, weight, etc. as other field indicators).

Steps to reproduce

  1. Visit https://commons.wikimedia.org/wiki/Special:UploadWizard
  2. Select media and press "Continue"
  3. Select a license and then press "Next"
  4. Fill out the Title, Description, and Date Fields
  5. Press "Next"
  6. Receive one confusing dialog

Expected behavior
If I fill out the required fields the form should submit. Having a 3rd state (recommended) adds an unclear response to submitting the form.

If an upload is missing a recommended field there should be a more obvious indication as to which field is being requested.
"We recommend you fill in the "X" field(s)."

See the dialog for one of the required fields as an example. The icon provides a clear indication that this is the field. The icon is different from the other 'information' icons on the form. (Note that we're reusing the "information" icon in this form - one that is consistent between fields (and interactive), one that is not.

Event Timeline

Restricted Application added a project: Multimedia. · View Herald TranscriptSep 20 2016, 3:17 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 311982 had a related patch set uploaded (by Matthias Mullie):
Display warnings in confirmation window

https://gerrit.wikimedia.org/r/311982

Restricted Application added a subscriber: Matanya. · View Herald TranscriptSep 21 2016, 1:23 PM
matthiasmullie moved this task from Untriaged to Needs code review on the Multimedia board.

Change 311982 merged by jenkins-bot:
Display warnings in confirmation window

https://gerrit.wikimedia.org/r/311982

If I fill out the required fields the form should submit. Having a 3rd state (recommended) adds an unclear response to submitting the form.

I don't think we should remove the warnings in general. UploadWizard is expected to provide some guidance for new users, and categories are indeed recommended – I think the only reason they're not required is because the category system is poor and it's possible to actually not find anything relevant. We have other ones too that are probably more useful than this one anyway.

matmarex closed this task as Resolved.Sep 27 2016, 5:54 PM
matmarex removed a project: Patch-For-Review.

After the change:

I'll mark this as resolved. See T145674 for discussion about the design of the warning labels near the field.