Page MenuHomePhabricator

Revert change of noindex-category from Non-indexed pages to Noindexed pages in English i18n
Closed, ResolvedPublic

Description

rMW522dcec59c7a01e53eb14bd22b9906378d13685f changed the English noindex-category from "Noindexed pages" to "Non-indexed pages".

It's the name of a tracking category many wikis have created at the old name which has been a MediaWiki default for several years. There is no compelling reason for the change so it should be reverted to "Noindexed pages". (Change "noindex-category": "Non-indexed pages" back to "noindex-category": "Nonindexed pages" in languages/i18n/en.json.)

Discussed at https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)#Category:Non-indexed_pages where the author of the change said "Open a phab task and ill fix in the morning".

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 23 2016, 2:34 AM
JJMC89 assigned this task to Zppix.Sep 23 2016, 2:38 AM
JJMC89 triaged this task as Medium priority.
JJMC89 renamed this task from Revert change of noindex-category from Non-indexed pages to Noindexed pages to Revert change of noindex-category from Non-indexed pages to Noindexed pages in English i18n.Sep 23 2016, 2:42 AM
JJMC89 updated the task description. (Show Details)
JJMC89 added a subscriber: JJMC89.
Aklapper raised the priority of this task from Medium to Needs Triage.Sep 23 2016, 8:40 AM

There is no compelling reason for the change so it should be reverted to "Noindexed pages".

Well, I'd say there is: Proper English. :)

Which specific problems are created by the name change? That would help understand and evaluate this request.

Which specific problems are created by the name change? That would help understand and evaluate this request.

It has been "noindexed pages" since the tracking category was added in 2009: https://www.mediawiki.org/wiki/Special:Code/MediaWiki/57020
https://www.wikidata.org/wiki/Q4989245 shows many Wikimedia wikis have created "Category:Noindexed pages". Other wikis also have.

Wikis which have created the default category name during the last 7 years may have hidden it, added pages to it with other methods like templates, documented and linked it, added it to watchlists, and so on. Now pages using NOINDEX are suddenly moved to a new red unhidden category. It creates confusion. Many editors at these wikis will probably have trouble finding the cause and getting their MediaWiki:noindex-category changed.

The names of old tracking categories should not be changed unless there is a serious problem with the name. If it is changed, it should be clearly announced in advance. https://www.mediawiki.org/wiki/MediaWiki_1.28/wmf.20 only says:
git #522dcec5 - Cleaned up some un needed wording in the English i18n file

The html tag added by NOINDEX is called https://en.wikipedia.org/wiki/noindex
Derived terms like noindexed and noindexing are common both in MediaWiki documentation and the outside World. See e.g. https://www.mediawiki.org/wiki/Help:Controlling_search_engine_indexing

Aklapper triaged this task as High priority.Sep 23 2016, 2:16 PM
Aklapper added subscribers: Zppix, Amire80.

Now pages using NOINDEX are suddenly moved to a new red unhidden category. It creates confusion. Many editors at these wikis will probably have trouble finding the cause and getting their MediaWiki:noindex-category changed.

Thanks a lot for explaining, this is helpful!

Zppix added a comment.Sep 23 2016, 2:20 PM

Okay im working on it at this moment

Change 312524 had a related patch set uploaded (by Zppix):
Revert noindex-category change from change 302061

https://gerrit.wikimedia.org/r/312524

Note that these translations are also changed during this invalid code changing:

  • Noindex-category/ast changed by @Xuacu on 20 Sep
  • Noindex-category/cdo changed by @GnuDoyng on 19 Sep
  • Noindex-category/egl changed by @Lévi on 16 Sep
  • Noindex-category/my changed by @Ninjastrikers on 20 Sep
  • Noindex-category/tt-cyrl changed by @Ильнар on 22 Sep

Should their translations also be reverted?

Oriciu added a subscriber: Oriciu.Sep 26 2016, 3:26 PM

As for ast translation, it will be fine by following the original string, so it should be reverted if the code is reverted.

Zppix added a comment.Oct 7 2016, 2:51 PM

@Liuxinyu970226 I don't quite understand what you mean by invalid code changing as this task was to smash a bug i unintentionally caused.

Zppix changed the task status from Open to Stalled.Oct 8 2016, 4:32 PM

Possibly completed awaiting reply from @Liuxinyu970226

Change 312524 merged by jenkins-bot:
Revert noindex-category change from change I233ce58fd82a1dbc57b3ab58ce669b23a5781b57

https://gerrit.wikimedia.org/r/312524

Bawolff added a subscriber: Bawolff.Oct 8 2016, 6:36 PM

This is going to create a slight mess, as it takes a long time for the tracking category change to propogate....

Change 314836 had a related patch set uploaded (by Zppix):
Typo correction based upon Ibe781441d999b00b1157aaebd69f37dddde1579f

https://gerrit.wikimedia.org/r/314836

Change 314836 abandoned by Zppix:
Typo correction based upon Ibe781441d999b00b1157aaebd69f37dddde1579f

Reason:
Re read diffs and prev phab tasks fixed and abandoned change because of user error on both ends sorry for the inconvience

https://gerrit.wikimedia.org/r/314836

Zppix closed this task as Resolved.Oct 8 2016, 7:30 PM

Assumed resolved unless anyone else has any other changes that are related needing done.