Page MenuHomePhabricator

Phabricator search results take a long time to execute
Closed, ResolvedPublic

Description

Phabricator full-text search terms for common terms like "test" or "Wikimedia" take a long time to display. The search for "Wikimedia-ro" took so long that I eventually got the error "504 Gateway Time-out". Phabrictor search performance should be much faster. I recall Phabricator search having acceptable speed in the past, so my guess is that something is wrong with the Phabricator search tool.

Event Timeline

Pine created this task.Sep 25 2016, 12:26 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 25 2016, 12:26 AM
Pine updated the task description. (Show Details)Sep 25 2016, 12:26 AM
Pine updated the task description. (Show Details)
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptSep 25 2016, 12:37 AM

Thanks for taking the time to report this.

Numbers and exact steps (as there are several search interfaces) are welcome to allow reproducing.

Entering wikimedia-ro in the search field on the top right on this very page (which in my case defaulted to the scope of "Open tasks", see the dropdown in front of the search field) took 39 seconds here, bypassing the browser cache.

Using the global search at https://phabricator.wikimedia.org/search/query/advanced/ took 37 seconds, bypassing the browser cache.

Using https://phabricator.wikimedia.org/maniphest/query/advanced/ and searching for "Contains Words = wikimedia-ro" (query URL: https://phabricator.wikimedia.org/maniphest/query/cLHE_cemD1dG/#R ) and bypassing the browser cache took 69 seconds here

Pine added a comment.Sep 26 2016, 5:08 AM

Thanks for confirming that searches are taking a very long time.

It seems to me that search results should appear in about 3 seconds max, not 37 to 69 seconds. What are the next steps to get this situation addressed? Thanks.

From the top of my head:

I believe you may have hit myisam limit, we switched to innodb and when I search now it take a few secs more then normal but not 20 or 30 secs.

Is this fixed for you?

It works for me.

Pine closed this task as Resolved.Sep 29 2016, 2:38 PM
Pine claimed this task.

Thanks @Paladox. My search results are now loading in a reasonable (though still not lightning quick) amount of time. I am marking this as resolved.

Your welcome

For the records, T146910 covers the myisam / innodb topic