Page MenuHomePhabricator

For related changes make category changes switchable.
Closed, ResolvedPublic

Description

In related changes articles added to a category are now also shown as:

Categorie:Wikipedia:Coördinaten op Wikidata‎ 17:03. . Wikidatist (Talk | contribs) (:Boonesmolen aan categorie toegevoegd)

While usefully, it should probably not being flagged as a normal edit and perhaps be switchable. Opening a ticket to track the wish.

Event Timeline

Akoopal created this task.Sep 25 2016, 9:39 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 25 2016, 9:39 PM

@Akoopal: What are steps to reproduce this? URL welcome to the tool on Tool Labs that you added as project; but your description sounds more like being about Special:RecentChangesLinked (MediaWiki-Special-pages) instead?
Thanks!

A URL where you see this is:

https://tools.wmflabs.org/erwin85/relatedchanges.php?lang=nl&family=wikipedia&category=Molen&d=10&submit=Submit&ignore=

This is not a bug or something. Related changes is a tool to see changes in for example articles in a category tree. I noticed that in the recent changes tables adding and removing to a category is now logged as well, and mimicking the normal recent changes page, I think these changes should be switchable as well, same as I already did a while back with the Wikidata changes.

This ticket is mainly to log this low prio wish, likely I pick it up myself when I have time.

How useful is the "hidewikidata" option? I'm tempted to remove it and just add AND rc_type <= 4 after line 184 WHERE sc_depth < ' . $d . '.

If I understand you correctly you want to just always hide wikidata and category edits? I do think it is usefull to see the wikidata-edits, marked as such, and similar to see the category edits. Do you know which rc_type number the category changes gets? Then it is not to difficult to build in later. At the moment I am on holiday till end of october, but can look at it after that.

I do think it is usefull to see the wikidata-edits, marked as such, and similar to see the category edits.

Ok then, nevermind.

Do you know which rc_type number the category changes gets?

6 https://www.mediawiki.org/wiki/Manual:Recentchanges_table#rc_type

Akoopal closed this task as Resolved.Dec 4 2016, 10:50 PM
Akoopal claimed this task.

This has now been implemented, there is now an option to 'hide category edits' same way as others.