Page MenuHomePhabricator

Kibana's Mailing List data sources do not include recent activity on wikitech-l mailing list
Closed, ResolvedPublic

Description

  1. Go to https://wikimedia.biterg.io:443/goto/514a5b01d78faae47ae07c68bb9d9589
  2. See that graphs end in August 2014 for activity on wikitech-l@ mailing list.
  3. Go to mailing list archives at https://lists.wikimedia.org/pipermail/wikitech-l/ and see that's not correct: There's activity after August 2014.

Event Timeline

Aklapper triaged this task as High priority.Sep 26 2016, 11:26 AM
Aklapper created this task.

There is a problem with the data collection, look:

https://wikimedia.biterg.io:443/goto/0cdea3035ff546ab89518b14558c3a38

Let's find out why ..

Still an issue.

Lcanasdiaz moved this task from Backlog to Doing on the wikimedia.biterg.io board.Nov 21 2016, 9:48 AM
Aklapper closed this task as Resolved.Nov 23 2016, 10:27 AM
Aklapper reopened this task as Open.Nov 23 2016, 12:11 PM

@Lcanasdiaz: As https://wikimedia.biterg.io/app/kibana#/dashboard/Data-Status currently has indexing issues, I went to
https://wikimedia.biterg.io/app/kibana#/dashboard/MailingLists (default filter: Last 2 years).
Looking at the "Mailing Lists" widget in the upper right corner, wikitech-l is not listed.
Changing the filter to Last 5 years, wikitech-l is now listed first in the "Mailing Lists" widget in the upper right corner.

So I still think this is not resolved as wikitech-l had activity recently.

Aklapper renamed this task from Kibana's Mailing List data sources are outdated to Kibana's Mailing List data sources do not include recent activity on wikitech-l mailing list.Nov 23 2016, 12:12 PM
Aklapper updated the task description. (Show Details)Dec 15 2016, 10:52 AM

The mailing list returned some errors we did not catch by mistake. According to our developers this is fixed with the version of the stack so we will migrate you to have the latest software. We didn't do it before due to the structure currently used is not modular, the new structure based on independent docker containers allow us to upgrade easily all the environments. We'll push to have this before end of next week so you'll start getting regular updates more often.

Aklapper closed this task as Resolved.Feb 28 2017, 1:57 PM

Thanks Lcanasdiaz!
Closing as resolved as I can confirm that this is fixed: https://wikimedia.biterg.io:443/goto/514a5b01d78faae47ae07c68bb9d9589 lists activity after 2014 for the wikitech-l mailing list, and https://wikimedia.biterg.io:443/goto/4caa3b3e09fa2c9b8738b60971112a23 with its 2years filter lists wikitech-l in the "Mailing Lists" widget.

Qgil awarded a token.Mar 1 2017, 6:07 PM