Page MenuHomePhabricator

Phab Advanced Search no longer showing typical results
Closed, ResolvedPublic

Description

The following teams use Advanced Search queries to list their related projects:

It appears something has broken this search functionality, as no results are given.

Note: This is different from Maniphest advanced search.

Related Objects

StatusAssignedTask
Resolvedmmodell
Resolvedjcrespo
Resolvedmmodell
ResolvedNone
ResolvedAklapper
Resolveddemon
Resolveddemon
Resolvedchasemp
Resolvedchasemp
Declinedchasemp
Declinedchasemp
Resolvedchasemp
ResolvedFriedhelmW
Resolvedmmodell
DeclinedNone
Resolved ksmith
ResolvedNone
Resolvedchasemp
Resolvedmmodell
Resolvedmmodell
Resolvedmmodell
Resolvedmmodell
Resolvedmmodell
Resolvedmmodell
DuplicateNone
Resolvedmmodell
Resolvedmmodell
DeclinedNone
ResolvedMarostegui
Resolvedmmodell

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 27 2016, 5:20 PM
Paladox added a subscriber: Paladox.EditedSep 27 2016, 5:23 PM

I belive there was a search problem yesterday and they are reindexing search currently.

It may take a while to reindex everything since they had to switch from myisam to innodb which does not support full text searches unless your using either MySQL 5.6 or 5.7 not sure which one or mariadb 10+ not sure which version were using for phab.

Task about search problems is T146673

hashar added a subscriber: 20after4.
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptSep 27 2016, 5:32 PM

The innodb fulltext search index may not behave exactly the same as the old search engine. I would like to experiment with elasticsearch again since it might have improved since we originally tried it out back in 2014-15

Paladox added a comment.EditedSep 27 2016, 10:54 PM

+1 to using elasticsearch, @mmodell could you setup a separate task for that and possibly make that a high priority please?

Elasticsearch has been supported since https://secure.phabricator.com/D10955

Tgr added a subscriber: Tgr.Sep 27 2016, 11:26 PM

I'm actually not sure what to make of this issue. The abovementioned projects show up in the global search autocomplete dropdown. That would seem to indicate that they have already been indexed, however, the results are inconsistent if you press enter to go to the search results page.

hashar added a subscriber: hashar.Sep 28 2016, 8:10 AM

I have tried all three examples mentioned and they know yield the appropriate result. I guess it is all related to the search index still being reindex.

From Greg link to db1048 writes:

Thus I would just mark this as resolved the root cause being the fix for the database contention (T146673) eg switching from MyISAM to Innodb with full reindexing.

mmodell closed this task as Resolved.Sep 28 2016, 8:14 AM
mmodell claimed this task.

Ok I had to reindex projects using the --force argument, e.g:

twentyafterfour@iridium:/srv/phab/phabricator$ sudo bin/search index --type PhabricatorProject --force

@hashar: The database reindex didn't actually fix it until I specifically reindexed projects with --force

Tgr added a comment.Sep 28 2016, 8:40 AM

Search quality for multiple terms is still extremely poor. E.g. for the query phabricator search over half of the top 10 results (including the first one) don't even mention Phabricator. T146843, which should be the obvious winner, is no. 12.

Paladox added a comment.EditedSep 28 2016, 10:22 AM

@mmodell Maybe we will want to also do --force for manifest tasks to per ^^

@Tgr: Hopefully T146843: Re-evaluate how we implement phabricator's search engine will address the quality of results. I don't think innodb is doing a very good job.

@Paladox: That would take several days to complete. The index is huge.

hashar removed a subscriber: hashar.Sep 29 2016, 8:56 AM