Page MenuHomePhabricator

Images on mobile site don't load when javascript is selectively blocked on mobile
Closed, DeclinedPublic

Description

When using uBlock origin to selectively block javascript from Wikipedia, the "noscript" tag fails to activate and the fallback thumbnails do not appear on any wikipedia pages.

To reproduce, set up uBlock Origin with the following dynamic filters (either of the two lines by themselves will trigger the issue):

wikipedia.org * 1p-scripts block
wikipedia.org * inline-scripts block

Then go to this page and you will see that non-infobox images are missing. This issue started maybe a month or so ago, I assume that's when lazy-loading went into place. I suspect the issue is that because uBlock is selectively blocking elements of the page rather than blocking all scripts, the browser does not render noscript tags. This occurs on both Firefox Mobile and Chrome for Linux.

I'm not sure of a good mitigation, but it would be a good idea if images loaded automatically on mobile if the "lazy-load" script fails to trigger. I'm not sure if it's possible to modify a page before the image requests are sent out, but possibly it could be done by dynamically changing all image tags to "lazy load" image tags as the page is loading.

Event Timeline

0x0077BE created this task.Sep 29 2016, 9:21 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 29 2016, 9:21 PM
TheDJ closed this task as Declined.Mar 10 2017, 10:13 AM
TheDJ added a project: MobileFrontend.
TheDJ added a subscriber: TheDJ.

This seems like a problem with uBlock to me. If you use stuff like this, then that is the type of problem that you can expect to experience with a website. I see no reason why we should jump through hoops to fix uBlock's shortcomings.