Page MenuHomePhabricator

Feedback dialog loses user input in case of failure
Closed, ResolvedPublic1 Story Points

Description

From User:Storkk:

Using VE on Commons. I have now twice typed a detailed bug report using VE's own "Help -> Leave feedback about this software", and upon clicking submit get the helpful error message "Error: Unable to post to given feedback title" and lost the entire report. In case of error, the report should be echoed back in the Error dialog box so that at least it can be copied/pasted. The Subject field contained no special characters and wasn't overly long.
Secondly, the Submit Feedback dialog links to "VisualEditor/Feedback" on Commons (ie. https://commons.wikimedia.org/wiki/VisualEditor/Feedback - a page which doesn't exist) rather than here.

Event Timeline

Elitre created this task.Sep 30 2016, 11:15 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 30 2016, 11:15 AM
Storkk added a subscriber: Storkk.Sep 30 2016, 11:43 AM

Please treat this as a Feature Request to echo back the input text when displaying any Error message.

The initial error appears to be unreproducible, and the second part is T125400.

Easy way to test (on Chromium, other browsers probably have something similar): open the feedback dialog, then open the developer tools and check the "Offline" checkbox in "Network" tab.

Clicking "Submit" will close the dialog and display an entirely new one:

Instead, it should keep the dialog open and display the error message in the standard way. For example, the file upload dialog does it right:

(well, that error message is far from perfect, but it's still better than closing the dialog; and we have it filed as T132611)

This tool is technically part of MediaWiki core (mediawiki.feedback) and used in some other places, but VE is probably the most prominent (and the original).

matmarex claimed this task.Sep 30 2016, 7:47 PM
matmarex triaged this task as Normal priority.

Might as well fix it, since I already looked into it.

Change 313616 had a related patch set uploaded (by Bartosz Dziewoński):
mw.feedback: Use standard OOjs UI dialog error handling

https://gerrit.wikimedia.org/r/313616

With the patch:

I forgot how nice these errors are, there's even a built-in retry button ;)

matmarex renamed this task from Error: Unable to post to given feedback title to Feedback dialog loses user input in case of failure.Sep 30 2016, 7:52 PM
Jdforrester-WMF closed this task as Resolved.Oct 3 2016, 6:04 PM
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.

Change 313616 merged by jenkins-bot:
mw.feedback: Use standard OOjs UI dialog error handling

https://gerrit.wikimedia.org/r/313616