Page MenuHomePhabricator

"## label ##" section label syntax incorrectly parsed as numbered list syntax in Bengali Wikisource (due to local "Easy_LST" gadget removal)
Closed, ResolvedPublic

Description

While transcluding a portion of pages into main namespaces, we follow the guideline in the link below -
https://en.wikisource.org/wiki/Help:Transclusion#How_to_transclude_a_portion_of_a_page

Instead of using <section begin="label" /> at the beginning and <section end="label" /> at the end of each portions, we use the following short syntax, which gives the same result

## label ##

Now, for last few days, this syntax is not transcluding the portions of pages in Bengali Wikisource. In stead its showing like this

১.    ১. label ##

(১ is 1 in Bengali)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 4 2016, 1:37 PM
Bodhisattwa updated the task description. (Show Details)Oct 4 2016, 1:38 PM
Aklapper added a comment.EditedOct 4 2016, 2:57 PM

Hi @Bodhisattwa, thanks for taking the time to report this!
Unfortunately this report lacks some information. If you have time and can still reproduce the problem, please add a more complete description to this report. Ideally, a list of exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. A link to a test case where the problem can be seen would also be helpful. Thanks!

Bodhisattwa updated the task description. (Show Details)Oct 4 2016, 4:10 PM

@Aklapper, please check if the description is ok now.

@Bodhisattwa: Thanks! Do you have an example link (testcase) to a page on Bengali Wikisource where the problem can be seen?

@Aklapper, I have reproduced the problem in a test page in Bengali Wikisource. please check this page.

Aklapper renamed this task from ## label ## syntax not working in Bengali Wikisource to "## label ##" section label syntax incorrectly parsed as numbered list syntax in Bengali Wikisource.Oct 5 2016, 3:17 PM
Aklapper triaged this task as High priority.Oct 5 2016, 3:21 PM
Aklapper added a project: Regression.

Thanks! I can reproduce now. And I cannot reproduce on en.wikisource. :-/

The shorthand LST syntax is provided by a gadget called Easy_LST. It's present on Bengali Wikisource, but not in Gadgets-definition. It was removed by @jayantanth on 8 September 2016, with the comment "remove gadget, fixed from common.js" but there doesn't seem to be anything in common.js.

Bodhisattwa closed this task as Resolved.Oct 6 2016, 1:31 AM
Bodhisattwa claimed this task.

Thanks @Samwilson, I have added it again in the Gadgets-definition. Its ok, now.

Bodhisattwa removed Bodhisattwa as the assignee of this task.Oct 6 2016, 1:35 AM
Aklapper renamed this task from "## label ##" section label syntax incorrectly parsed as numbered list syntax in Bengali Wikisource to "## label ##" section label syntax incorrectly parsed as numbered list syntax in Bengali Wikisource (due to local "Easy_LST" gadget removal).Oct 6 2016, 6:20 AM