Non-terrible email address handling
Closed, ResolvedPublic

Description

Right now we detect users' email from their Wikipedia profile and automatically update it (from that profile data) whenever they log in. This may not be desired/expected behavior (e.g. users might want an email address specific to this platform, and might be surprised if their TWLight email changes simply because their WP email has). We need to:

  • think about/ask what users' desired behavior actually is
  • update our user email setting accordingly (change update_from_wikipedia, expose email change features on the user profile page, whatever)
ThatAndromeda renamed this task from Not terrible email handling to Non-terrible email address handling.

I could use some guidance from those of you in direct contact with TWL users - do you have a read on what their expectations are, or do we need to gather data?

ThatAndromeda added a subscriber: Ocaasi_WMF.

@Ocaasi_WMF , assigning this to you because I'm blocked on needing to know more about the desired behavior here. Feel free to assign it back to me when there's a clearer spec.

I think it would make sense that users' emails follow their Wikimedia account email unless they explicitly change it in the platform, perhaps with a box that allows them to reset back to following their Wikimedia account.

If we don't have an email from Wikipedia, prompt user to enter one locally on the platform. Require this before/at the point of application as a check.

Status update: I've got what I think is workable code written, but I need to write tests for it and make sure before I deploy it.

ThatAndromeda closed this task as Resolved.Feb 9 2017, 1:59 PM