Page MenuHomePhabricator

Wrong "Log in" link title on private wiki
Closed, ResolvedPublic

Description

Steps to reproduce

  1. deploy a fresh installation of MediaWiki
  2. make wiki private by setting in LocalSettings.php:
$wgGroupPermissions['*']['edit'] = false;
$wgGroupPermissions['*']['read'] = false;
  1. navigate to the wiki, notice that any page will say "Connection required"
  2. hover mouse cursor over "Log in" link on the top right corner to display its "title" attribute

Actual result
The title reads "You are encouraged to log in; however, it is not mandatory [alt-shift-o]".

Expected result
Since the wiki is private, unregistered users cannot view or edit pages, hence the title attribute of the "log in" link should read something like "You need to log in to use this wiki [alt-shift-o]".

Note
This issue has been noticed on a french language installation.

Event Timeline

Tinss created this task.Oct 13 2016, 6:02 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 13 2016, 6:02 AM
Filip claimed this task.Jan 8 2017, 5:21 PM

Change 331220 had a related patch set uploaded (by Filip):
Added diffrent log-in tooltip to private wiki

https://gerrit.wikimedia.org/r/331220

Change 331220 merged by jenkins-bot:
[mediawiki/core@master] Add different log-in tooltip for private wikis

https://gerrit.wikimedia.org/r/331220

Filip closed this task as Resolved.Apr 27 2017, 9:15 AM

Merged, marking as resolved