Page MenuHomePhabricator

User rights get overridden when using <translate> tags on "Category:" pages
Closed, InvalidPublic

Description

Hi,

Here is my config :

MediaWiki 1.27.1
PHP 5.6.26 (cgi-fcgi)
MySQL 5.7.15-log
ICU 57.1

I use the Translate extension, and therefore have assigned the appropriate user rights:

$wgGroupPermissions['user']['translate'] = false;
$wgGroupPermissions['user']['translate-manage'] = false;
$wgGroupPermissions['user']['translate-import'] = false;
$wgGroupPermissions['user']['pagetranslation'] = false;
$wgGroupPermissions['user']['translate-messagereview'] = false;
$wgGroupPermissions['user']['translate-proofr'] = false;
$wgGroupPermissions['user']['translate-groupreview'] = false;

$wgGroupPermissions['bureaucrat']['translate'] = true;
$wgGroupPermissions['bureaucrat']['translate-manage'] = true;
$wgGroupPermissions['bureaucrat']['translate-import'] = true;
$wgGroupPermissions['bureaucrat']['pagetranslation'] = true;
$wgGroupPermissions['bureaucrat']['translate-messagereview'] = true;
$wgGroupPermissions['bureaucrat']['translate-proofr'] = true;
$wgGroupPermissions['bureaucrat']['translate-groupreview'] = true;
$wgGroupPermissions['bureaucrat']['skipcaptcha'] = true;

It works perfectly on normal pages, but on "Category:"-type pages, when I add the <translate> tags, it doesn't work anymore.

I can provide other information if needed.

Event Timeline

Tuxxic created this task.Oct 13 2016, 9:26 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 13 2016, 9:26 AM

Sorry, it's not a bug : I forgot to protect the NS_CATEGORY namespace. Please close

Aklapper closed this task as Invalid.Oct 13 2016, 11:18 AM

Glad you found the reason! Changing task status to "invalid" then. :)