Page MenuHomePhabricator

MediaWiki:Wm-license-cc-conditions-share_alike-text is inaccurate for CC-BY-SA-1.0
Closed, ResolvedPublic

Description

https://translatewiki.net/wiki/MediaWiki:Wm-license-cc-conditions-share_alike-text/en: (emphasis mine)

If you alter, transform, or build upon this work, you may distribute the resulting work only under the same or similar license to this one.

However, https://creativecommons.org/licenses/by-sa/1.0/deed.en:

ShareAlike — If you remix, transform, or build upon the material, you must distribute your contributions under the same license as the original.

This was reported at https://commons.wikimedia.org/wiki/Template_talk:Cc-by-sa-1.0#Similar_licences_not_allowed

Details

Related Gerrit Patches:
mediawiki/extensions/WikimediaMessages : masterUpdate wording for 'wm-license-cc-conditions-share_alike-text'

Event Timeline

Restricted Application added subscribers: JEumerus, Aklapper. · View Herald TranscriptOct 14 2016, 6:30 PM

Looks like your link is a typo because it links to a BY-NC-SA license, which is a non-free CC license.

Also, even CC BY-SA 4.0 summary page also said same clause, so is this also inaccurate for any CC BY-SA licenses?

Jarekt added a subscriber: Jarekt.Oct 24 2016, 12:41 PM

The issue seems to be only with wording of CC-BY-SA-1.0. All CC-BY-SA licenses have the same summaries, but they have different language in the long version of the license (the only one that actually matter). I think we will need to modify the text of our CC-BY-SA-1.0 summary.

Nemo_bis edited projects, added WikimediaMessages; removed I18n.Oct 24 2016, 1:02 PM
Reedy reopened this task as Open.Oct 24 2016, 1:03 PM
Reedy added a subscriber: Reedy.

I don't feel that creating local messages is the correct way to fix this. These should presumably be added to WikimediaMessages under licensetexts, and then be available for all wikis?

Why locally rather than in the extension where those messages are stored?

Most of important messages on Commons are translated outside of Wikimedia universe on https://translatewiki.net. Unfortunately the process of setting it up is undocumented and the only person I know that was able to do it was Multichill. After the initial burst of message translations was moved to translatewiki in 2009, most of the translations since is done through: templates, Extension:Translate, local messages or Wikidata. I opted for local message because it is the most similar to translatewiki messages. Also "only" about 30k files are affected by this change and the number is not likely to increase significantly.

Reedy added a comment.Oct 24 2016, 1:33 PM

Most of important messages on Commons are translated outside of Wikimedia universe on https://translatewiki.net. Unfortunately the process of setting it up is undocumented and the only person I know that was able to do it was Multichill. After the initial burst of message translations was moved to translatewiki in 2009, most of the translations since is done through: templates, Extension:Translate, local messages or Wikidata. I opted for local message because it is the most similar to translatewiki messages. Also "only" about 30k files are affected by this change and the number is not likely to increase significantly.

Put the english translation in the extension, get it merged, it becomes live on translatewiki, other languages can then freely translate it

Are you talking about https://www.mediawiki.org/wiki/Extension:Translate? As far as I know that has nothing to do with https://translatewiki.net. I can set up a local template that will translate the https://commons.wikimedia.org/wiki/MediaWiki:Wm-license-cc-conditions-share_alike-text_(Cc-by-sa-1.0) phrase using the extension, but it will not become live on translatewiki and will not show up in list of available messages the way translatewiki messages do.

If someone can add the content of https://commons.wikimedia.org/wiki/MediaWiki:Wm-license-cc-conditions-share_alike-text_(Cc-by-sa-1.0) to TranslateWiki under the above or similar name, I can handle using it in commons template and deleting then unused MediaWiki messages I created. Unless someone else beats me to it.

Since you are probably the most active person maintaining those templates, it would vastly more efficient and extremely helpful if you could submit such patches yourself.

I already linked the docs on what files to change; https://www.mediawiki.org/wiki/Gerrit/Tutorial explains how to send a patch. Please do ask on IRC (#wikimedia-dev) if you need more help.

"same license" at https://creativecommons.org/licenses/by-sa/1.0/deed.en has an explanatory popup saying that a compatible license can also be used. What about:

If you remix, transform, or build upon the material, you must distribute your contributions under the same (or a compatible) license as the original.

Compatible licenses: https://creativecommons.org/share-your-work/licensing-considerations/compatible-licenses

MarcoAurelio removed Jarekt as the assignee of this task.Dec 4 2018, 10:50 AM

Change 477507 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[mediawiki/extensions/WikimediaMessages@master] Update wording for 'wm-license-cc-conditions-share_alike-text'

https://gerrit.wikimedia.org/r/477507

The current wording also say "may" when CC say "must". I've fixed that as well in the patch above.

Restricted Application added a project: User-MarcoAurelio. · View Herald TranscriptDec 4 2018, 11:28 AM

Adding @RStallman-legalteam since the patch at https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/WikimediaMessages/+/477507/ is blocked until a sign-off for wmf-legal can be obtained (if you're not the person to review this kind of things, could you please point us to the right person within the legal dept. to do so? thanks).

MarcoAurelio triaged this task as Medium priority.Dec 19 2018, 11:57 AM

@Jdforrester-WMF WMF-Legal isn't replying. Maybe you could approach them or can we go forward w/o their input? Thanks.

@Jdforrester-WMF Good day. Can we have another update about the review here and/or in the patch? Thanks.

Change 477507 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[mediawiki/extensions/WikimediaMessages@master] Update wording for 'wm-license-cc-conditions-share_alike-text'

https://gerrit.wikimedia.org/r/477507

Will re-ping. Sorry. :-(

Legal have confirmed that they're OK with this change. Let's get it done.

Change 477507 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Update wording for 'wm-license-cc-conditions-share_alike-text'

https://gerrit.wikimedia.org/r/477507

Jdforrester-WMF closed this task as Resolved.May 23 2019, 4:23 PM
Jdforrester-WMF removed a project: Patch-For-Review.