Page MenuHomePhabricator

Regression: Empty watchlists are confusing
Closed, ResolvedPublic

Description

As a user who has never added anything to my watchlist
When I click on the watchlist link in the main menu
I see a confusing blank screen like so:

(Test this by visiting a wiki you have never used)

We have some code in SpecialMobileWatchlist that used to deal with this.
SpecialMobileWatchlist::showEmptyList

We should fix it and add a browser test.

Ignoring the list/modified tabs, it should look like this:

List viw:

Feed view:

Event Timeline

Restricted Application added a subscriber: Aklapper. ยท View Herald TranscriptOct 18 2016, 11:30 PM
Jdlrobson renamed this task from Empty watchlists are confusing to Regression: Empty watchlists are confusing.Oct 18 2016, 11:30 PM
โ€ข jhobs triaged this task as High priority.Oct 20 2016, 5:14 PM
โ€ข jhobs moved this task from Incoming to Triaged but Future on the Readers-Web-Backlog board.
Jdlrobson updated the task description. (Show Details)Oct 20 2016, 5:52 PM

Change 323337 had a related patch set uploaded (by Jdlrobson):
Fix empty watchlist views

https://gerrit.wikimedia.org/r/323337

Change 323337 merged by jenkins-bot:
Fix empty watchlist views

https://gerrit.wikimedia.org/r/323337

bmansurov reassigned this task from Jdlrobson to ovasileva.Nov 29 2016, 6:36 PM
bmansurov added a subscriber: ovasileva.

@ovasileva looks good?

ovasileva closed this task as Resolved.Nov 30 2016, 12:34 PM

looks good!

Change 325321 had a related patch set uploaded (by Jdlrobson):
Logged in user tests do not work on beta cluster

https://gerrit.wikimedia.org/r/325321

Jdlrobson claimed this task.Dec 5 2016, 4:52 PM
Jdlrobson added a subscriber: zeljkofilipin.

It seems the step "I am logged in as a new user" is not working on labs. You can see in the screenshot the user has been making edits. I guess the beta cluster uses the same user for everything unlike the per commit runs? cc @zeljkofilipin

With that in mind it's probably worth disabling this test on the beta cluster for the time being...

Change 325321 merged by jenkins-bot:
Logged in user tests do not work on beta cluster

https://gerrit.wikimedia.org/r/325321

We should create a task to re-enable the test on beta cluster with a different user.

@bmansurov I think you can create out a task in the release engineering team backlog that it's not possible to do these sort of tests on the cluster and that we need a reliable way to do test code paths for new users. The issue is in the Ruby mediawiki_api module/integration config not MobileFrontend.

Given this test will run on @integration I wouldn't be too concerned that it's omitted in this build.

A related task has been created: T152432. Feel free to edit as you see fit.

bmansurov closed this task as Resolved.Dec 5 2016, 7:57 PM

The build T148599#2848015 passed.