Page MenuHomePhabricator

NDA LDAP access for Lydia Pintscher and Daniel Kinzler
Closed, ResolvedPublic

Description

Please add me to the NDA LDAP group, so I can access Pivot (https://pivot.wikimedia.org/) and similar services (listed in https://wikitech.wikimedia.org/wiki/LDAP_Groups).

Thanks!

PS: Perhaps it would make sense to add other WMDE employees that have signed an NDA as well.

EDIT by Elukey:

The WMDE people would need to access pivot.w.o to observe Wikidata's traffic patterns. This use case is very critical for them and it will allow a better understanding of Wikidata's usage from external users. I verified with WMF Legal over email that their NDA is up to date and correct. I don't see any blocker in granting them this access since the use case is really compelling and the paperwork has been completed months ago correctly.

Event Timeline

daniel created this task.Oct 21 2016, 1:01 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 21 2016, 1:01 PM
hoo added a subscriber: hoo.Oct 21 2016, 1:04 PM

PS: Perhaps it would make sense to add other WMDE employees that have signed an NDA as well.

I think they're all included by now… especially all which have shell access to production (like you have).

PS: Perhaps it would make sense to add other WMDE employees that have signed an NDA as well.

I think they're all included by now… especially all which have shell access to production (like you have).

That's what I thought, but it's apparently not the case.

elukey added a subscriber: elukey.Oct 26 2016, 10:15 AM
elukey triaged this task as Normal priority.Oct 26 2016, 10:18 AM
elukey added a comment.EditedOct 26 2016, 10:21 AM

This could be probably my fault since I am the one that configured pivot.w.o to check the following LDAP groups (Apache directives):

Require ldap-group cn=wmf,ou=groups,dc=wikimedia,dc=org
Require ldap-group cn=nda,ou=groups,dc=wikimedia,dc=org

I tried to check WMDE members via the following queries but didn't find them:

ldapsearch -x -b ou=groups,dc=wikimedia,dc=org cn=nda  | grep member
ldapsearch -x -b ou=groups,dc=wikimedia,dc=org cn=wmf | grep member

Now if I didn't make any trivial mistakes, there is a gap between people that have signed an NDA and people in the nda LDAP group.

How should we proceed?

People who you've confirmed to have signed an NDA can just be added to the nda LDAP group.

elukey added a comment.EditedOct 26 2016, 5:08 PM

People who you've confirmed to have signed an NDA can just be added to the nda LDAP group.

Thanks! Any quick way to verify it in bulk? Is there something that I can check or should I just ask Legal/other-team ?

Newer ones may show up on the L2-signers list. People who signed the volunteer NDA long enough ago, like me, won't be found there. I actually don't know who would have them. Maybe WMF Legal?

elukey updated the task description. (Show Details)Oct 27 2016, 8:51 AM

Yes, WMF Legal has 'older' NDAs.

WMF Legal has also the new NDAs that are on paper and not on the L2-signers list. I checked with Manprit and Rachel via email, they confirmed that Daniel has signed a correct NDA.

I am in contact with the WMDE people over email and they have a solid use case to use pivot, namely observing Wikidata's traffic patterns.

Lydia Pintscher is Wikidata's project manager and she has asked for Pivot's access as well, for the same motivations. I verified her NDA as well via email.

I added both to the nda LDAP group to unblock the WMDE use case. I am going to add a not in the description to reflect this action.

elukey renamed this task from NDA access for Daniel to NDA LDAP access for Lydia Pintscher and Daniel Kinzler.Oct 31 2016, 8:58 AM
elukey updated the task description. (Show Details)

While re-checking https://wikitech.wikimedia.org/wiki/Volunteer_NDA I realized that I missed one key point, namely final sign-off from C-Level staff. I removed the entries that I just added to nda a minute ago, will wait for the final sign-off before proceeding.

@Wwes: Hi! This request is to grant access to the nda LDAP group to Lydia Pintscher and Daniel Kinzler (Wikimedia Germany, Wikidata project). They would need to consult pivot.wikimedia.org to observe and analyse Wikidata's traffic patterns. I verified with WMF-Legal that their NDAs are compliant with our policies; would you mind to review this request as final sign-off?

elukey closed this task as Resolved.Nov 2 2016, 9:02 AM
elukey claimed this task.

Re-added Daniel and Lydia to the nda group!